Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt installer (Qt Online Installer for Windows) has installed MinGW which tries (and fails) to access drive D:



  • I have installed Qt recently (a 5.3.2 version) using the "Qt Online Installer for Windows". It has installed MinGW 4.8.2

    When loading a project in Qt Creator, g++ is launched and tries to access the D: drive. (I have to choose Cancel/Retry/Continue). Hopefully, it doesn't prevent future operations (even the compilation of the project).

    When I try to launch g++ via mingw32-make (in a CMD console), I have the same popup window, but I don't manage to compile the project.



  • Hi, if you just do "g++ -v" in a CMD console, does it still prompt for the D: drive?



  • Yes, "g++ -v" ask for a D: drive access, but with Continue or cancel, it displays its version, and its configuration :

    @
    C:\Qt\hp-simulator\qt>c:\Qt\Tools\mingw482_32\bin\g++ -v
    Using built-in specs.
    COLLECT_GCC=c:\Qt\Tools\mingw482_32\bin\g++
    Target: i686-w64-mingw32
    Configured with: ../../../src/gcc-4.8.2/configure --host=i686-w64-mingw32 --build=i686-w64-mingw32 --target=i686-w64-mingw32 --prefix=/mingw32 --with-sysroot=/c/mingw482/i686-482-posix-dwarf-rt_v3-rev3/mingw32 --with-gxx-include-dir=/mingw32/i686-w64-mingw32/include/c++ --enable-shared --enable-static --disable-multilib --enable-languages=ada,c,c++,fortran,objc,obj-c++,lto --enable-libstdcxx-time=yes --enable-threads=posix --enable-libgomp --enable-libatomic --enable-lto --enable-graphite --enable-checking=release --enable-fully-dynamic-string --enable-version-specific-runtime-libs --disable-sjlj-exceptions --with-dwarf2 --disable-isl-version-check --disable-cloog-version-check --disable-libstdcxx-pch --disable-libstdcxx-debug --enable-bootstrap --disable-rpath --disable-win32-registry --disable-nls --disable-werror --disable-symvers --with-gnu-as --with-gnu-ld --with-arch=i686 --with-tune=generic --with-libiconv --with-system-zlib --with-gmp=/c/mingw482/prerequisites/i686-w64-mingw32-static --with-mpfr=/c/mingw482/prerequisites/i686-w64-mingw32-static --with-mpc=/c/mingw482/prerequisites/i686-w64-mingw32-static --with-isl=/c/mingw482/prerequisites/i686-w64-mingw32-static --with-cloog=/c/mingw482/prerequisites/i686-w64-mingw32-static --enable-cloog-backend=isl --with-pkgversion='i686-posix-dwarf-rev3, Built by MinGW-W64 project' --with-bugurl=http://sourceforge.net/projects/mingw-w64 CFLAGS='-O2 -pipe -I/c/mingw482/i686-482-posix-dwarf-rt_v3-rev3/mingw32/opt/include -I/c/mingw482/prerequisites/i686-zlib-static/include -I/c/mingw482/prerequisites/i686-w64-mingw32-static/include' CXXFLAGS='-O2 -pipe -I/c/mingw482/i686-482-posix-dwarf-rt_v3-rev3/mingw32/opt/include -I/c/mingw482/prerequisites/i686-zlib-static/include -I/c/mingw482/prerequisites/i686-w64-mingw32-static/include' CPPFLAGS= LDFLAGS='-pipe -L/c/mingw482/i686-482-posix-dwarf-rt_v3-rev3/mingw32/opt/lib -L/c/mingw482/prerequisites/i686-zlib-static/lib -L/c/mingw482/prerequisites/i686-w64-mingw32-static/lib -Wl,--large-address-aware'
    Thread model: posix
    gcc version 4.8.2 (i686-posix-dwarf-rev3, Built by MinGW-W64 project)@



  • Hmm looks ok. Just guessing: what happens if you instead type "notepad" in a CMD console, does that also prompt for the D: drive?



  • notepad doesn't prompt for the D: drive.

    Opening g++ in a hex editor shows some path like

    D:/msys64/mingw32/libexec/gcc/

    Replacing D:/msys64 by C:/msys64 is not enough... but I think MinGW should be recompiled with others options.



  • I also have those "D:/msys64/mingw/..." paths in my g++ and it works fine anyway.

    I used "Process Monitor":http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx to see what "g++ -v" does, it looks for files going through the directories stored in the PATH setting, maybe you've got a "D:" stored there somewhere?



  • Thanks for the answer; Process Monitor is a nice tool to have. But it does not show a D:\ file access from g++. (filtering on g++ or any C:\Qt Path)
    No D:\ in the PATH nor any other environment variables listed by the SET command.


Log in to reply