Dleploying Qt5 QML video on Windows 7



  • I have added a QML Video player to my project. This was necessary to make video background behind the rendered text as image. I have got it working with QtCreator. But when I tried to deploy it on Windows, outside the QtCreator, I cannot get video to play. All I have is the black back screen. It appears that I am missing something that is related to video playback. All other qml code works fine.

    I used "Windows Deployment Tool":http://qt-project.org/doc/qt-5/windows-deployment.html#the-windows-deployment-tool to get all needed dlls and plugins.

    here is the deployment directory listing that I get after running Windows Deployment Tool on my executable:
    @
    C:.. ..\bin2\accessible
    C:.. ..\bin2\accessible\qtaccessiblequick.dll
    C:.. ..\bin2\accessible\qtaccessiblewidgets.dll
    C:.. ..\bin2\bearer
    C:.. ..\bin2\bearer\qgenericbearer.dll
    C:.. ..\bin2\bearer\qnativewifibearer.dll
    C:.. ..\bin2\iconengines
    C:.. ..\bin2\iconengines\qsvgicon.dll
    C:.. ..\bin2\icudt52.dll
    C:.. ..\bin2\icuin52.dll
    C:.. ..\bin2\icuuc52.dll
    C:.. ..\bin2\imageformats
    C:.. ..\bin2\imageformats\qdds.dll
    C:.. ..\bin2\imageformats\qgif.dll
    C:.. ..\bin2\imageformats\qicns.dll
    C:.. ..\bin2\imageformats\qico.dll
    C:.. ..\bin2\imageformats\qjp2.dll
    C:.. ..\bin2\imageformats\qjpeg.dll
    C:.. ..\bin2\imageformats\qmng.dll
    C:.. ..\bin2\imageformats\qsvg.dll
    C:.. ..\bin2\imageformats\qtga.dll
    C:.. ..\bin2\imageformats\qtiff.dll
    C:.. ..\bin2\imageformats\qwbmp.dll
    C:.. ..\bin2\imageformats\qwebp.dll
    C:.. ..\bin2\libgcc_s_dw2-1.dll
    C:.. ..\bin2\libstdc++-6.dll
    C:.. ..\bin2\libwinpthread-1.dll
    C:.. ..\bin2\mediaservice
    C:.. ..\bin2\mediaservice\dsengine.dll
    C:.. ..\bin2\mediaservice\qtmedia_audioengine.dll
    C:.. ..\bin2\platforms
    C:.. ..\bin2\platforms\qwindows.dll
    C:.. ..\bin2\playlistformats
    C:.. ..\bin2\playlistformats\qtmultimedia_m3u.dll
    C:.. ..\bin2\printsupport
    C:.. ..\bin2\printsupport\windowsprintersupport.dll
    C:.. ..\bin2\qmltooling
    C:.. ..\bin2\qmltooling\qmldbg_qtquick2.dll
    C:.. ..\bin2\qmltooling\qmldbg_tcp.dll
    C:.. ..\bin2\qt_cs.qm
    C:.. ..\bin2\qt_de.qm
    C:.. ..\bin2\qt_fi.qm
    C:.. ..\bin2\qt_hu.qm
    C:.. ..\bin2\qt_it.qm
    C:.. ..\bin2\qt_ja.qm
    C:.. ..\bin2\qt_ru.qm
    C:.. ..\bin2\qt_sk.qm
    C:.. ..\bin2\qt_uk.qm
    C:.. ..\bin2\Qt5Core.dll
    C:.. ..\bin2\Qt5Gui.dll
    C:.. ..\bin2\Qt5Multimedia.dll
    C:.. ..\bin2\Qt5MultimediaQuick_p.dll
    C:.. ..\bin2\Qt5Network.dll
    C:.. ..\bin2\Qt5PrintSupport.dll
    C:.. ..\bin2\Qt5Qml.dll
    C:.. ..\bin2\Qt5Quick.dll
    C:.. ..\bin2\Qt5Sql.dll
    C:.. ..\bin2\Qt5Widgets.dll
    C:.. ..\bin2\QtMultimedia
    C:.. ..\bin2\QtMultimedia\declarative_multimedia.dll
    C:.. ..\bin2\QtMultimedia\plugins.qmltypes
    C:.. ..\bin2\QtMultimedia\qmldir
    C:.. ..\bin2\QtMultimedia\Video.qml
    C:.. ..\bin2\QtQuick.2
    C:.. ..\bin2\QtQuick.2\plugins.qmltypes
    C:.. ..\bin2\QtQuick.2\qmldir
    C:.. ..\bin2\QtQuick.2\qtquick2plugin.dll
    C:.. ..\bin2\MyExecutable.exe
    C:.. ..\bin2\Data.sqlite
    C:.. ..\bin2\sqldrivers
    C:.. ..\bin2\sqldrivers\qsqlite.dll
    C:.. ..\bin2\sqldrivers\qsqlmysql.dll
    C:.. ..\bin2\sqldrivers\qsqlodbc.dll
    C:.. ..\bin2\sqldrivers\qsqlpsql.dll
    @

    here is what I have in the *.pro file

    @
    QT += core
    gui
    widgets
    network
    sql
    qml
    quick
    printsupport
    multimedia
    @

    I have only one qlm file and this is what I import:
    @
    import QtQuick 2.2
    import QtMultimedia 5.0
    @

    the qml file is part of the resource file.

    I tried to include the following libraries: libEGL.dll and libGLESv2.dll, but since I do not use Open GL, it does not help.

    I searched the site, but no post seems to help.

    Could someone help me to find what I might be missing in the deployment directory that will enable QML Video Playback.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.