[SOLVED] Static build doesn't include 'qmlscene' and QtCreator complains



  • bq. I'm trying create static Qt libraries, alongside my shared ones. With the exception of swapping -shared for -static, all configuration flags remain identical and the static build compiles without any noticeable hiccups.
    When creating a kit in QtCreator however, it gives me the warning "No qmlscene installed." for the static libraries and hides the kit from the project wizard. I'm on Linux x86_64 with Qt5.3.2.
    Any ideas how I could solve this, either by building Qt differently or by tricking QtCreator into ignoring the absent tool (which I don't need anyway)?

    After another try I was able to set up- and use the kit despite the warning. Unfortunately I don't know what I did differently, so I can't offer a solution to anyone in the same situation.



  • @Adrian5 Can this be marked un-solved until there is more definitive solution? I am facing the exact same issue, but on win32 with VS 2010 and QT 5.4.1 source built with the -static flag.

    Also, what do you mean by "another try"? Did you re-build QT, or just re-configure it in QtCreator?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.