[SOLVED] The application was unable to start correctly (0xc000007b)



  • I am a total C++ n00b, but I created an app that runs successfully from Qt Creator. When I try to deploy a release version of the app, it would not run. I followed the steps here:

    http://qt-project.org/wiki/Deploy_an_Application_on_Windows

    But I am getting an error "The application was unable to start correctly (0xc000007b). Click OK to close the application." The above link said if the steps there do not work, post in the forum, so here I am. :-)

    I would appreciate any help! Thank you in advance!


  • Moderators

    Hi, and welcome to the Qt DevNet!

    Congratulations on successfully building and running your app in Qt Creator :)

    Error 0xc000007b is commonly caused by mixing up 32-bit and 64-bit libraries. The first thing to check is: Did you copy the Visual Studio runtimes (msvcp120.dll/msvcr120.dll)? If so, do they have the same bit-ness as your app?

    If that didn't help, let's start with some simple diagnostics:

    You followed the guide to deploy your application to a target PC. Is this the same PC as the one where your program ran successfully in Qt Creator?

    What version of Windows are running? It is 32-bit or 64-bit?

    Which version of Qt are did you use? (Version number + bitness + compiler + OpenGL-or-not)

    Did you use QML in your application?

    Which folder(s) did you take the DLLs from? (Please give the absolute path of the folders in your PC)



  • Thank you for the reply JKSH. Based on what you said, I looked at what I had done. I realized I had compiled using MSVC 64-bit, and then I followed the directions in the link literally. That put 32-bit MingW dependencies in. I changed to MSVC 32, compiled a release version, then copied the necessary files and folders from "C:\Qt\5.3\msvc2013" which is the 32-bit. It runs fine now. Thank you again! You got me in the right direction! Time to clean up. :-)


  • Moderators

    You're welcome! Happy coding :)



  • @JKSH Hi, You are absolutely right that "Error 0xc000007b is commonly caused by mixing up 32-bit and 64-bit libraries. " The best solution is to reinstall Visual C++. But there are some other fixes tool.

    I found that Error 0xc000007b can also solved by re installing DirectX and .Net framework.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.