Mipsel compile qt5.3 error



  • I compiled on a Loongson computer where debian operating system is installed. The compiling environment is as follows:

    ##loongson@Loong:~/qt/qt-everywhere-opensource-src-5.3.2$ uname -a
    Linux Loong 2.6.32-loongson3 #1 SMP Tue Jul 22 16:01:16 CST 2014 mips64 GNU/Linux

    ##loongson@Loong:~/qt/qt-everywhere-opensource-src-5.3.2$ gcc -v
    Using built-in specs.
    COLLECT_GCC=gcc
    COLLECT_LTO_WRAPPER=/usr/lib/gcc/mipsel-linux-gnu/4.7/lto-wrapper
    Target: mipsel-linux-gnu
    Configured with: ../src/configure -v --with-pkgversion='Debian 4.7.2-5' --with-bugurl=file:///usr/share/doc/gcc-4.7/README.Bugs --enable-languages=c,c++,go,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.7 --enable-shared --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.7 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libitm --enable-plugin --with-mips-plt --with-arch-32=mips2 --with-tune-32=mips32 --enable-targets=all --with-arch-64=mips3 --with-tune-64=mips64 --enable-checking=release --build=mipsel-linux-gnu --host=mipsel-linux-gnu --target=mipsel-linux-gnu
    Thread model: posix
    gcc version 4.7.2 (Debian 4.7.2-5)

    ##loongson@Loong:~/qt/qt-everywhere-opensource-src-5.3.2$ g++ -v
    Using built-in specs.
    COLLECT_GCC=g++
    COLLECT_LTO_WRAPPER=/usr/lib/gcc/mipsel-linux-gnu/4.7/lto-wrapper
    Target: mipsel-linux-gnu
    Configured with: ../src/configure -v --with-pkgversion='Debian 4.7.2-5' --with-bugurl=file:///usr/share/doc/gcc-4.7/README.Bugs --enable-languages=c,c++,go,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.7 --enable-shared --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.7 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libitm --enable-plugin --with-mips-plt --with-arch-32=mips2 --with-tune-32=mips32 --enable-targets=all --with-arch-64=mips3 --with-tune-64=mips64 --enable-checking=release --build=mipsel-linux-gnu --host=mipsel-linux-gnu --target=mipsel-linux-gnu
    Thread model: posix
    gcc version 4.7.2 (Debian 4.7.2-5)

    then configure && make

    g++ -c -include .pch/Qt5Core -pipe -pthread -I/usr/include/glib-2.0 -I/usr/lib/mipsel-linux-gnu/glib-2.0/include -O3 -fvisibility=hidden -fvisibility-inlines-hidden -std=c++0x -Wall -W -D_REENTRANT -fPIC -DQT_NO_MTDEV -DQT_NO_XKB -DQT_NO_USING_NAMESPACE -DQT_BUILD_CORE_LIB -DQT_BUILDING_QT -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_BEFORE=0x050000 -DELF_INTERPRETER="/lib/ld.so.1" -DQT_USE_ICU -DPCRE_HAVE_CONFIG_H -DQT_CORE_LIB -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -I../../mkspecs/linux-g++ -I. -I../../include -I../../include/QtCore -I../../include/QtCore/5.3.2 -I../../include/QtCore/5.3.2/QtCore -Iglobal -I../3rdparty/pcre -I../3rdparty/harfbuzz/src -I../3rdparty/md5 -I../3rdparty/md4 -I../3rdparty/sha3 -I.moc -o .obj/qobject.o kernel/qobject.cpp
    {standard input}: Assembler messages:
    {standard input}:13665: Error: Illegal operands sync 0' make[3]: *** [.obj/qobject.o] error 1 make[3]: Leaving directory/home/loongson/qt/qt-everywhere-opensource-src-5.3.2/qtbase/src/corelib'
    make[2]: *** [sub-corelib-make_first] error 2
    make[2]: Leaving directory /home/loongson/qt/qt-everywhere-opensource-src-5.3.2/qtbase/src' make[1]: *** [sub-src-make_first] error 2 make[1]: Leaving directory/home/loongson/qt/qt-everywhere-opensource-src-5.3.2/qtbase'
    make: *** [module-qtbase-make_first] error 2


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.