Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[SOLVED] QTCreator stopped working after updates MacOS



  • Hello All,

    I have a BIG problem. After updating mac os to version 10.9.5, xcode to 6.0.1 and comand line tools to 6.0, QtCreator has stopped working.

    I can open qtcreator and navigate through my projects. But if I try to build them everything fails. First, it doesn't find the c++ libraries. I get "<ostream> not found", "<vector> not found", etc etc.

    I've solved it adding to the project file "INCLUDEPATH += /usr/include/c++/4.2.1/" before I had "INCLUDEPATH += /usr/include"...

    But now it fails because it can't find <OpenGL/gl.h> which is included (# include <OpenGL/gl.h>) in line 102 of qopengl.h....

    What is going on??? Any is having the same problems????

    Thanks!!!!



  • Maybe it can help...

    I have seen that while compiling, clang gives me this warning:

    clang: warning: no such sysroot directory: '/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.8.sdk'



  • I have found the solution here:

    http://stackoverflow.com/questions/25940368/qt5-target-conditionals-not-found

    But, I have had to change qdevice.pri that is found inside the installation folder of qt:

    Qt/5.3/clang_64/mkspecs/qdevice.pri

    I hope it can help!!

    Best!



  • Had the same problem today as well and the above solution worked for me.


Log in to reply