Segmentation on application startup. QT5.3.2



  • Hello,
    I was using QT5.3.1 with QT Creator 3.1.2 and everything worked well, then I've installed QT5.3.2 with QT Creator 3.2.1, but after compiling, when I start the application (every application, even the application template generated by QT creator) , I get a segmentation with error 0xc0000020. Seems that it doesn't find some dll, but the configuration of the build run is exactly the same of the other version but with path to 5.3.1 instead of 5.3.1.
    Some suggestions?

    Thanks in advance
    Best regards



  • Hi, if you use Visual Studio, try reinstalling that and apply the latest update (no. 4 for MSVC2012 and no. 3 for MSVC2013).



  • Thank you for your answer, and I'm sorry but I've forgotten to mention that I'm using mingw:
    Qt 5.3.2 for Windows 32-bit (MinGW 4.8.2, OpenGL, 737 MB)
    Regards



  • Check the kit you are using with new Qt creator. Select the correct tool chain with the kit. The configuration files used for Qt creator resides on the same location as that of the previous installation. So if you have multiple Qt creator installations on your system then they will try to load and update the same conf files. Check if your configuration with the new installation is correct and see if helps.



  • Thank you, the build&run configuration is correct. Do I need to look also in other configurations?
    p.s. I've uninstalled previous QT and reinstalled 5.3.2, but still the same result.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.