Important: Please read the Qt Code of Conduct -

Upgraded to latest Xcode and...

  • the debugger is giving me an error message at startup:

    bq. .o file "/usr/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/crt3.o" more recent than executable timestamp in "/Developer/Applications/Qt/Qt"
    Could not open OSO file /usr/lib/gcc/i686-apple-darwin10/4.2.1/x86_64/crt3.o to scan for pubtypes for objfile /Developer/Applications/Qt/Qt

    I couldn't find any other posts on this, so I'm wondering whether there's something weird in my build configuration. Any suggestions on how to make this go away?

    Thanks. Oh: Intel Mac, latest OS, etc.

  • what were you trying to do when this error message came up?

  • Nothing...just went into the debugger view and hit the "Start Debugging" icon. Hadn't even begun to declare variables in main() yet.

  • XCode 4 (if that's what you mean with "latest") might be just too new :-/

  • Moderators

    You could try rebuilding the debugging helpers in Tools->Options->Qt.

  • Too new in what way? This should have been a pretty minor release from Apple. Hard to believe it would have necessitated rework by clients...

  • Ary you talking about an XCode 3.2.x update or the brand new XCode 4?

  • Oh,'re right, Volker...this was a major release. My bad.

    Tobias: I don't have an "Options" choice under my "Tools" menu.

  • "Qt Creator -> Preferences (or shortcut cmd-comma) -> Qt4" is the menu path for that in OS X version.

Log in to reply