Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

SpellChecker Plugin for QtCreator 3.2.0



  • Hi,

    I have created a new release for my SpellChecker Plugin for QtCreator 3.2.0 (Windows). This updates adds many updates and improvements over the previous release.

    Please head over to my "github page":https://github.com/CJCombrink/SpellChecker-Plugin or download the latest "release":https://github.com/CJCombrink/SpellChecker-Plugin/releases/tag/v0.1.0 and test the plugin if you like.

    Any feedback will be appreciated.

    Regards,



  • Thanks, I installed it and I have some questions.

    The plugin shows up in the plugin manager and under Tools/Options. I selected Hunspell in the Spell Checker drop box and downloaded the English dictionary and selected it in the Dictionary field. I have no idea where to get or generate (?) a user dictionary, so I left that empty.

    Under Tools, the Spell Check menu item is grayed out. Is it because of the user dictionary and if so how do I create one?



  • Rincewind,

    The User Dictionary as mentioned in the README is a custom file. I think that you need to at least select a Folder where the plugin should create the user dictionary (I will confirm the exact steps a bit later and update the README accordingly).

    Sorry for this, after that is done, restart Qt Creator and it should be working.

    Normally the Spell Check options will only become available when the cursor is over a misspelled word.

    Please let me know if you have any more problems or questions.



  • The user dictionary isn't mentioned in the README file...

    I added a user dictionary, restarted Creator, still doesn't work.



  • If you open the SpellChecker Options page, is the following set:

    • Spell Checker: Hunspell
    • Dictionary: *.dic (english dictionary with *.dic extension)
    • User Dictionary: *.udic (any file wit *.udic extension)

    And then, if you open a file with spelling mistakes in the comments, open the output panel, does it list any words in the panel?

    (I am busy looking into this, but the answers to the above might help so long)

    Sorry for the troubles



  • As I indicated in the previous posts, all the fields in the options page have been set.

    I added "ueeruewo" to one of the comments, but the spelling mistakes panel is empty.



  • Sorry rincewind, at the moment I am not able to assist. I have no Idea what might be wrong.

    I will attempt later on to see what could cause something like this and provide an update. At the moment I do not have a Windows PC set up where I can test.

    Regards,



  • @rincewind

    I will shortly start looking into possible causes for this.

    One thing that I have thought of (something that I have experienced), might it be that the file you are editing is not part of the Active Project, or no active project is set?



  • @rincewind,

    I could not find anything obvious that would result in such behavior. Which dictionary are you using, perhaps I can test also with the same one?



  • It seems to be the issue with editing a file that isn't in the active project. I work with a session with quite a few projects, some plugins and libraries and a test application. The test application is the active project for obvious reasons. So, a lot of the time I'm editing code in one of the libraries. Bummer!


Log in to reply