Problem with decoding AAC internet stream on Linux using QtMultimedia

  • Hi,

    I tried to play Internet radio stream on my Debian using QMediaPlayer in Qt5.3. But when I tried to play radio from I get information from application that could not decode stream.

    Maybe some one had the same problem. I'm using Debian x64 and QtSDK from

    Information from :
    ICY 200 OK
    icy-notice1:<BR>This stream requires <a href="">Winamp</a><BR>
    icy-notice2:SHOUTcast Distributed Network Audio Server/Linux v1.9.8<BR>
    icy-name:RMF FM

    My code:
    QMediaPlayer *player;
    player = new QMediaPlayer;
    qDebug() << player->errorString();
    qDebug() << player->state();
    qDebug() << player->error();


  • Welcome to DevNet!
    Do you see any error messages in a console?

  • Hi,

    Here is output in console:
    Error: "Nie udało się zdekodować strumienia."
    Error: "Nie udało się zdekodować strumienia."

    "Nie udało się zdekodować strumienia." - mean that could not decode stream.

    I don't know, maybe something is missing in my OS? Before I start application I run:
    jackd -d alsa

  • Looks like some decoder is missing.
    Do you have all gstreamer0.10 packages installed?

  • No,

    Only this packages
    ii gstreamer0.10-alsa:amd64
    ii gstreamer0.10-ffmpeg
    ii gstreamer0.10-gconf:amd64
    ii gstreamer0.10-plugins-base:amd64
    ii gstreamer0.10-plugins-good:amd64
    ii gstreamer0.10-plugins-ugly:amd64
    ii gstreamer0.10-pulseaudio:amd64
    ii gstreamer0.10-x:amd64
    ii libgstreamer0.10-0:amd64
    ii libgstreamer0.10-0:i386

  • Try to run in a terminal
    gst-launch-0.10 playbin uri=""

    It should say what plugin is missing.

  • Here is output from gst-launch-0.10:
    Failed to create secure directory (/run/user/1000/pulse): No access
    ERROR: from element /GstPlayBin:playbin0/GstDecodeBin:decodebin0/ffdec_aac:ffdec_aac0: Could not decode stream.
    Additional diagnostic information:
    gstffmpegdec.c(2213): gst_ffmpegdec_audio_frame (): /GstPlayBin:playbin0/GstDecodeBin:decodebin0/ffdec_aac:ffdec_aac0:
    Decoding of AAC stream by FFMPEG failed.

    Installed gstreamer0.10-plugins-bad solved problem.

    Thank you for help.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.