QML Video is not playing properly in Ubuntu machine (Solved)



  • Hello,

    I have got an error like this when i run the QML Video file,

    Warning: "No decoder available for type 'video/x-h264, stream-format=(string)avc, alignment=(string)au, level=(string)3, profile=(string)main, codec_data=(buffer)014d401effe10017674d401ee8805017fcb0800000030080000018078b168901000468ebef20, width=(int)640, height=(int)360, framerate=(fraction)24/1, pixel-aspect-ratio=(fraction)1/1, parsed=(boolean)true'."

    Please help me to solve this problem.

    Regards
    Ansif



  • Hi All,

    I got the solution for he above problem. Actually FFmpeg plugin for GStreamer 0.10 is not available in the official Ubuntu 14.04 repositories and because of this, the above warning occurs.

    I have installed the missing plugin using below commands and the problem is solved :),

    @sudo add-apt-repository ppa:mc3man/trusty-media
    sudo apt-get update
    sudo apt-get install gstreamer0.10-ffmpeg@

    Refer links:
    http://thebugfreeblog.blogspot.in/2014_05_01_archive.html
    http://www.webupd8.org/2014/03/get-firefox-and-phonon-gstreamer-to.html

    Regards
    Ansif


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.