[SOLVED] Google Maps API not showing Satellite Images under Windows 8.1



  • Hi guys,

    We've got a (Qt 5.3.0) QWebView showing a map via the Google Maps API in an application and we noticed under Windows 8.1 the satellite images do not appear. I checked it in the inspector and I saw the requests going out, correct content length, and everything, but no preview.

    It is working under Windows 8, although my Windows 8 VM also has Qt Creator and everything installed so that is somewhat unscientific.

    I even tried having the QWebView simply show maps.google.com, and the satellite images do not appear there either. I tried alternate user agents as well. I see requests going out to khms0.google.com/... with type image/jpeg and a non-zero Content-Length in the response header, but the Preview tab in the inspector says "This request has no preview available" where on Windows 8 and OS X it shows the satellite tile.

    Is this an SSL issue? Or something else potentially? The map works fine except for the satellite imagery not appearing.

    Thanks!



  • For what it's worth, I tried it without SSL and the outcome was the same. So it seems as if that is not a factor.



  • I think I have it narrowed down to the satellite images only appearing on Windows VM's that also have Qt installed. What might I be forgetting in my installer package that would enable the application to run and the map page to essentially work except for loading the satellite images?



  • I've got this sorted! I just needed the Qt/mingw482_32/plugins/imageformats folder in my distribution, containing qjpeg.dll. So it was indeed loading them, but had no way to decode them. All is well now and I hope this is helpful to someone else.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.