Missing MSVCP120.dll file at startup



  • I recently downloaded and installed Qt 5.3 and I get an error every time I open Qt Creator that says:
    "winrtrunner.exe - System Error"
    "The program can't start because MSVCP.dll is missing from your computer. Try reinstalling the program to fix this problem."
    Despite this error, the program seems to run fine. I'm searched this problem in a number of forums without luck. I uninstalled Qt 5.3 completely and re-installed it, but I still get the error. When I installed Qt Creator the first time around, I also downloaded a couple libraries (C-Image Library, Eigen Library, and the FLTK library), but shouldn't those have been deleted when I uninstalled Qt? Any help here would be appreciated.



  • Hi, when you installed Qt 5.3, did you specify "Windows Runtime 8.1" as well?
    Because winrtrunner is a utility program for the Qt for Windows Runtime, it requires Visual Studio 2013. And if it's not installed, that's why you get that error msg.



  • No, I just went to this site: http://qt-project.org/downloads. This site automatically generates a suggested download based on your operating system, which generated for me: "Qt Online Installer for Windows (14 MB)"
    I just downloaded that one and installed. It never asked me about any OS details.



  • Ok, perhaps the Qt Online installer selected "Windows Runtime 8.1" for you as a nice default? For example, maybe you're running on Windows 8.1 and got some Microsoft SDK installed.

    Anyway, start MaintenanceTool.exe in Qt's top directory, select Package Manager, open 5.3's tickboxes and see if you can deselect Windows Runtime.



  • I ran the MaintenanceTool.exe, but there is no option to deselect Windows Runtime. It gives me a list with the following:

    Qt - 1.0.4 (Checked)
    --> Qt 5.3 (Checked)
    --> Qt 5.2.1
    --> Qt 5.1.1
    --> Qt 5.1.0
    --> Qt 5.0.2
    --> Tools (Checked)
    --> Qt Cloud Services


  • Moderators

    Expand "Qt 5.3". You'll see the options there.



  • That worked! Big thanks to both hskoglund and JKSH for your help. I'm curious now, though. Why does Windows Runtime require Microsoft Visual Studio? Just curious.



  • Hi, perhaps I exaggerated, perhaps it doesn't require the whole enchilada i.e. Visual Studio 2013, it might suffice if you install the MSVC 2013 "redist DLLs":http://www.microsoft.com/en-us/download/details.aspx?id=40784



  • I installed Qt 5.3 using the online installer for Windows, got the same errors on start of QtCreator, but they stopped showing when I disabled the WinRT plugin.

    Don't know if that helps you guys, but I thought that I could mention it. :)


  • Moderators

    [quote author="pdavidmontoya" date="1401810918"]That worked! Big thanks to both hskoglund and JKSH for your help. I'm curious now, though. Why does Windows Runtime require Microsoft Visual Studio? Just curious.[/quote]You're welcome :)

    When you build a C++ program, you need to link your program to the standard C++ library for it to use low-level standard features (like math operations, file I/O, etc.).

    • Programs built with GCC need to link to libgcc_XXX.dll
    • Programs built with MSVC need to link to msvcXXX.dll

    When you select the WinRT option, Qt Creator will try to launch winrtrunner.exe in order to let you deploy WinRT apps. winrtrunner.exe is a program built with MSVC (specifically MSVC 2013), so it needs msvcp120.dll.



  • Simply installing Visual C++ 2013 Redistributable package fixed it for me.



  • Have you tried downloading msvcp120.dll? [EDIT: Untrusted link removed. --JKSH]


  • Moderators

    @shweps said:

    Have you tried downloading msvcp120.dll?

    Hi @shweps, the solution of installing msvcp120.dll has already been provided by @hskoglund (11 months ago) and @socrateos (8 months ago). Their solution is better because they point to the official Microsoft installer. I strongly discourage downloading DLLs from unofficial websites.



  • @pdavidmontoya

    Hello my name is jack.
    I fixed "MSVCP120.dll Missing Error" on my laptop past month. A guide help me to get rid of this issue without going to anywhere. i found this on google, you can also fix this issue with yourself.
    Visit for the complete Guide: [EDIT: Untrusted link removed. --JKSH]



  • Hi, as @JKSH says above, don't post links to sites of doubtful quality (I got "This connection is untrusted" when trying to download the "PC Repair Tool").

    Instead please use the official link to Microsoft's redistributable to solve this problem.



  • Hi, this sulutions didnt work for me. I have already installed all of msvc from official microsoft websites. "...missing MSVCR120.dll..." click "ok" and "...missing MSVCP120.dll..." allways when I try to open installation. May someone help me please?
    Thanks


  • Moderators

    @Filet said:

    I have already installed all of msvc from official microsoft websites.

    Which version?

    For MSVCP120.dll, install Visual C++ 2013 Redistributable.



  • It works! I had previously installed only 64 bit version of Visual C++ 2013 but now i try to install both of versions (64 and 32 bit) and it works! Thank you.



  • This post is deleted!


  • You can find the missing file on the Microsoft link below.

    https://www.microsoft.com/en-gb/download/details.aspx?id=40784

    Note: Even though you're running a 64bit OS, you should install both the x64 and x86 versions. Or you can also visit:
    [EDIT: Untrusted link removed. --JKSH]


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.