Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Problem creating plugins.qmltypes for QML



  • I'm using Qt 5.3.0 and Qt Creator on Windows 8 64bit to generate a MyModulePlugin.dll library for windows with mingw482_32. The DLL file was built from QML types but NO C++ files. I copied the DLL to C:/Test/MyModule and created a qmldir file containing
    @
    module MyModule
    plugin MyModulePlugin
    classname MyModulePlugin
    @

    When I run
    @
    C:\Qt\Qt5.3.0\5.3\mingw482_32\bin\qmlplugindump -nonrelocatable MyModule1.0 . > MyModule/plugins.qmltypes
    @

    in C:\Test I get the error
    @
    QQmlComponent: Component is not ready
    file:///C:/Test/typelist.qml:2:1: plugin cannot be loaded for module "MyModule": Plugin verification data mismatch in 'C:/Test/MyModule/MyModulePlugin.dll'
    @

    I tried it without -nonrelocatable but had the same error. Any suggestions?

    BTW, there are qmlplugindump files for each of the 7 windows kits but why are there none for the 3 android kits?



  • I'm getting more or less same troubles(with C++ declared qml component).
    Command line:
    @
    qmlplugindump -nonrelocatable MyModule 1.0 > imports/MyModule/plugins.qmltypes
    @

    or

    @
    qmlplugindump MyModule 1.0 imports > imports/MyModule/plugins.qmltypes
    @

    Both returns:
    @
    QQmlComponent: Component is not ready.
    "file:///imports/MyModule/typelist.qml:2:1: module "MyModule" plugin"mymoduleplugin" not found "
    @

    Is there any advice you could give me?



  • May I know how you resolved this issue? I am in same situation.


  • Qt Champions 2019

    @Noushad And you really expect that someone who was last online 2014 will answer you? Wow.


  • Lifetime Qt Champion

    @Noushad
    Hi
    I dont think it was resolved.
    Make a new forum post with enough details of Qt version used, platform and
    where in https://doc.qt.io/qtcreator/creator-qml-modules-with-plugins.html
    it fails. List any errors and the code used.


Log in to reply