QtIFW on-line: Cannot access Updates.xml in repository



  • I'm using QtIFW 1.5 to create an on-line installer. I've created the repository packages using repogen and uploaded the created directory to the server. When I run the installer, I get the following error:

    Could not fetch Updates.xml from repository: <repository url>. Error: Error downloading <repository url>/Updates.xml?423175335 - server replied: Not Acceptable.

    However, if I enter <repository url>/Updates.xml into a web browser, the xml file is displayed.

    Any ideas as to what could be making the installer unhappy?



  • Update: I discussed this problem with our hosting company, and they suggested setting the mime type: application/xml in the server settings. I did that, but no joy.

    Since I don't know what the http query is, I can't really figure out why the server is complaining. I looked through the source code and found where the downloader was being setup, but couldn't find anything related to the actual server query.

    Thanks.



  • SOLVED: The problem turned out to be a configuration issue on the server.



  • Could you please elaborate on those server settings? I am having the exact same issue on my shared host (hostmonster).

    Greetings,
    JeDi



  • The problem had to do with the MIME type settings (this was also on Hostmonster). From the C-Panel login in the Advanced section, select Mime Types. Create a user mime type of application/xml with extension .xml.

    There may be other problems. I worked with their help desk to get it resolved - I thought there was some MIME type default that needed to be removed, but I forget.

    Good luck!



  • Thanks for the info! I tried adding the application/xml mime type with the xml extension, both with and without the dot. It still doesn't work.

    I will try to get through their support and have it resolved that way, but I think this is something to address in QTIFW in the future. Or is hostmonster the only hosting solution that has problems with this?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.