Camera viewfinder fails to load in Lubuntu 14.04



  • Hi,

    I’m trying to use the camera viewfinder on Linux. The compilation works fine, but when I try to launch the program all I get is a black screen, with the following in stderr:

    @GStreamer-CRITICAL **: gst_object_ref_sink: assertion 'GST_IS_OBJECT (object)' failed@

    I tried both the Qt 5.2.1 from APT and 5.3.0 from the official online installer. Same result. I tried to install some stuff that seems related (libqt5multimedia5-plugins, for example), but nothing yields success. Is there something that I should install/compile to make this work?

    Thanks.

    p.s. For what it’s worth, the same application works perfectly on my OS X machine with Homebrew Qt.



  • uranusjr, I get the same problem when running the camera example. Do you have a solution for this problem? Thanks.



  • I ended up switching to another Linux distribution (Linux Mint Qiana, for the record), and after installing libqtmultimedia5-plugins everything works fine.

    Since Mint Qiana and Lubuntu 14.04 are both based on Ubuntu 14.04, I suspect Lubuntu has some plugin and/or codec dependency missing somewhere out of the box. But I really can’t tell what. Sorry. :(



  • How to install libqtmultimedia5-plugins? How can I tell if it is installed on my box? I cannot find it in Qt maintainence tool. Thanks.



  • I used the Qt distribution provided by APT. If you use Ubuntu (or its derivatives like Mint), you can install Qt libraries with

    @
    sudo apt-get install qt5-default libqt5multimediawidgets5 libqt5multimedia5-plugins
    @

    You may or may not need more packages; these work for me. Also note that the package name in my previous post is wrong. Sorry.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.