Unable to deploy Qt Android project



  • Hi,

    I have installed Qt 5.2.1 on my Ubuntu 12.4 LTS PC.
    I am trying to deploy a built in QT Example project called "application"
    I have followed all steps, and successfully setup the Android SDK,NDK and Apache ANT tool

    I have enabled USB debugging on my nexus 7, and Qt recognizes my nexus 7, and the PC ssh key has been successfully added to my nexus 7.

    The android project builds successfully(In Debug mode).
    But when i want to deploy the project(in Release mode) to my Nexus 7, I get the following build/deploy Errors.

    These are the build/deploy errors i get

    @09:13:01: The process "/usr/bin/make" exited normally.
    09:13:01: Starting: "/usr/bin/make" INSTALL_ROOT=/home/barath/Development/Android/projects/build-application-Android_for_armeabi_v7a_GCC_4_8_Qt_5_2_1-Release/android-build install
    install -m 755 -p "libapplication.so" "/home/barath/Development/Android/projects/build-application-Android_for_armeabi_v7a_GCC_4_8_Qt_5_2_1-Release/android-build/libs/armeabi-v7a/libapplication.so"
    09:13:01: The process "/usr/bin/make" exited normally.
    09:13:01: Starting: "/opt/Qt5.2.1/5.2.1/android_armv7/bin/androiddeployqt" --input /home/barath/Development/Android/projects/build-application-Android_for_armeabi_v7a_GCC_4_8_Qt_5_2_1-Release/android-libapplication.so-deployment-settings.json --output /home/barath/Development/Android/projects/build-application-Android_for_armeabi_v7a_GCC_4_8_Qt_5_2_1-Release/android-build --deployment bundled --install --ant /home/barath/Development/Android/apache-ant-1.9.4/bin/ant --android-platform '' --jdk /home/barath/Development/jdk1.7.0_51 --device 015d4a82200bec0f
    09:13:01: Pulling files necessary for debugging.
    09:13:01: Package deploy: Running command '/home/barath/Development/Android/adt-bundle-linux-x86_64-20140321/sdk/platform-tools/adb -s 015d4a82200bec0f pull /system/bin/app_process /home/barath/Development/Android/projects/build-application-Android_for_armeabi_v7a_GCC_4_8_Qt_5_2_1-Release/app_process'.
    09:13:01: Package deploy: Running command '/home/barath/Development/Android/adt-bundle-linux-x86_64-20140321/sdk/platform-tools/adb -s 015d4a82200bec0f pull /system/lib/libc.so /home/barath/Development/Android/projects/build-application-Android_for_armeabi_v7a_GCC_4_8_Qt_5_2_1-Release/libc.so'.
    /home/barath/Development/Android/adt-bundle-linux-x86_64-20140321/sdk/tools/android: 1: /home/barath/Development/Android/adt-bundle-linux-x86_64-20140321/sdk/tools/android: java: Permission denied
    /home/barath/Development/Android/adt-bundle-linux-x86_64-20140321/sdk/tools/android: 1: /home/barath/Development/Android/adt-bundle-linux-x86_64-20140321/sdk/tools/android: java: Permission denied
    /home/barath/Development/Android/adt-bundle-linux-x86_64-20140321/sdk/tools/android: 113: exec: java: Permission denied
    Build failed
    Building the android package failed!
    -- For more information, run this command with --verbose.
    Generating Android Package
    Input file: /home/barath/Development/Android/projects/build-application-Android_for_armeabi_v7a_GCC_4_8_Qt_5_2_1-Release/android-libapplication.so-deployment-settings.json
    Output directory: /home/barath/Development/Android/projects/build-application-Android_for_armeabi_v7a_GCC_4_8_Qt_5_2_1-Release/android-build
    Application binary: /home/barath/Development/Android/projects/build-application-Android_for_armeabi_v7a_GCC_4_8_Qt_5_2_1-Release/libapplication.so
    Android build platform: android-19
    Install to device: 015d4a82200bec0f
    Buildfile: build.xml does not exist!
    09:13:03: The process "/opt/Qt5.2.1/5.2.1/android_armv7/bin/androiddeployqt" exited with code 14.
    Error while building/deploying project application (kit: Android for armeabi-v7a (GCC 4.8, Qt 5.2.1))
    When executing step 'Deploy to Android device'
    09:13:03: Elapsed time: 00:07.@

    Since, java appears to face permission errors, i tried running Qtcreator as sudo, but still no luck.

    Any suggestion towards a fix, would be great.

    Thanks,
    Barath


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.