Image Gestures example does not work



  • I built and ran the Image Gesture example that came with my Qt 5.2.1 mingw install. It doesn't respond to any of the gestures I tried: pinch, pan, or swipe. Does this example only works in some OS versions?

    I am running Windows 8.1 with a touch screen (Dell XPS One 2710) and both my touchpads (Logitech T650 and Wacom Intuos Pen & Touch) don't work with it either.


  • Lifetime Qt Champion

    Hi,

    Since Qt 5.3 is about to go out, can you try with it ?



  • Tried 5.3RC1 and it's not much better.

    Only pinch and pan event are handled. Pinch always reports a scale factor of 1 so it never scales.

    It also doesn't work with either of my touchpads. Only touch screen works.


  • Lifetime Qt Champion

    Then you should have a look at the "bug report system":http://bugreports.qt-project.org to see if it's something known. If not please open a new report providing as much details as you can



  • Can't find anything on bugreport so filed a new one: https://bugreports.qt-project.org/browse/QTBUG-38925



  • hi SGaist,

    How about running on Qt 4.8.5 with linux-arm platform. Does it have some special notes to make it work?

    I have tried to cross compile it and run on MCU arm9, but no event come (only some event paint firstly).

    More infomation, i have configured env params and can run ok with single touch.

    @export QWS_MOUSE_PROTO=tslib:/dev/input/event0
    export TSLIB_CONSOLEDEVICE=none
    export TSLIB_TSEVENTTYPE=INPUT
    export PATH=/sbin:/usr/sbin:/bin:/usr/bin
    export TSLIB_FBDEVICE=/dev/fb0
    export TSLIB_TSDEVICE=/dev/input/event0
    export TSLIB_PLUGINDIR=usr/lib/ts
    export TSLIB_CONFFILE=/etc/ts.conf
    export TSLIB_CALIBFILE=/etc/pointercal
    export LD_LIBRARY_PATH=/opt/qt-arm/lib:$LD_LIBRARY_PATH@

    Thank you very much.


  • Lifetime Qt Champion

    Hi,

    Please don't highjack threads with unrelated questions (the only common point is the touch part)

    That's a bit vague. Did you check that tslib is working correctly ? That you have access to the input device ?



  • hi SGaist,

    I am so sorry about my mistake. I will more notice at posts later.

    tslib is config to work correctly with single touch. I mean i have access to the input device.

    I think it will be better to stop my question here. I will move it to suitable place.

    Sorry again.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.