Installing latest qt 1.1 Beta osx errors



  • After installin my qt offline version 1.1 I got this:

    GLSLEditor
    Could not resolve dependency 'Core(2.1.81)'
    Could not resolve dependency 'TextEditor(2.1.81)'
    Could not resolve dependency 'ProjectExplorer(2.1.81)'

    Macros
    Could not resolve dependency 'Core(2.1.81)'
    Could not resolve dependency 'Locator(2.1.81)'
    Could not resolve dependency 'Find(2.1.81)'
    Could not resolve dependency 'TextEditor(2.1.81)'

    QmlJSTools
    Could not resolve dependency 'TextEditor(2.1.81)'
    Could not resolve dependency 'ProjectExplorer(2.1.81)'
    Could not resolve dependency 'Locator(2.1.81)'
    Could not resolve dependency 'CppTools(2.1.81)'



  • I got the same thing. Any ideas? I installed by just taking the defaults.



  • well, after a complete uninstall running the python scripts to uninstall it and installing using the online version solved my problem

    but this last beta still have the qtquick 1.0 and qt 4.7.1



  • I have the same problem after installing using the offline installer. Hmm... Ok, I am going to try using the online installer and see how it goes.



  • first uninstall all, search for the uninstall.py and uninstallsdk.py



  • Thanks, I am going to do that now. Otherwise, have you come across problems with the Qt 4.7.2 version of macdeployqt? (See http://developer.qt.nokia.com/forums/viewthread/4239/ )



  • I cannot open that link.

    until now i have no errors. but the beta 1.1 still says that qt is 4.7.1,

    i've downloaded the 4.7.2 libs from the site and installed them (I couldn't choose the directory so I don't know if they overrided the previous ones) but on qt create i still find qqt 4.7.1 at least in the about



  • Oh, something else... where did you install Qt SDK 1.1? Unlike the 2010.05 version of Qt SDK (i.e. Qt Creator 2.0.1 and Qt 4.7.0) which would install under /Developer by default (if I recall correctly), Qt SDK 1.1 offers to install under my home directory by default, even if I use sudo...!?



  • [quote author="MAMartins" date="1299258629"]I cannot open that link.[/quote]Sorry, the forum clearly doesn't do a good at handling closing brackets. I had to add a space in front of it.



  • no problem :) but no, no problem until now, but i'm only doing some small apps to learn qt :)



  • [quote author="MAMartins" date="1299258629"]the beta 1.1 still says that qt is 4.7.1[/quote]Where does it say that? On Windows, I have this:
    @C:\Windows\system32>qmake --version
    QMake version 2.01a
    Using Qt version 4.7.2 in C:\QtSDK\Desktop\Qt\4.7.2\mingw\lib@



  • running that command I have the same output as you but going to the about on qt creator I have "Based on Qt 4.7.1 (64 bit)"

    and i don't get why they have on the documentation qtquick 1.1 and they still haven't released it with qt creator, its very confusion for people like me that are trying to get started...



  • For Qt Creator, my understanding is that it just means that Qt Creator itself was built using Qt 4.7.1, but Qt SDK 1.1 Beta still comes with Qt 4.7.2 (which itself is not a beta version). Whatever the case, I agree that it is all very confusing. Unnecessarily confusing in fact.



  • [quote author="MAMartins" date="1299258285"]first uninstall all, search for the uninstall.py and uninstallsdk.py [/quote]Are you sure that those files are under the Qt SDK folder? I can't see them anywhere (be it on Mac OS X, Windows or Linux). However, there is a file called SDKMaintenanceTool which can be used to add/remove things.



  • under machintosh hd -> developer -> tools



  • [quote author="MAMartins" date="1299261647"]under machintosh hd -> developer -> tools[/quote]Not on my Mac.



  • i have on mine.

    just try the online version then ;)



  • [quote author="MAMartins" date="1299262348"]i have on mine.

    just try the online version then ;)[/quote]That doesn't make sense to me. I mean that I can see that SDKMaintenanceTool file on Windows, Linux and Mac OS X. Although I wouldn't expect a python file to be present on the Windows version, I could easily expect such a file on Linux, yet I couldn't find one either.

    Did you have another version of Qt before installing Qt SDK 1.1 Beta? Another version which you wouldn't have completely uninstalled?



  • I don't think so. my previous version had 2 py files this one only has one, and after I ran the scripts on the previous version all the files were deleted, including the py files



  • Well, this is a mystery then.



  • just another one in the qt world lol


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.