QTCreator 3.1 design tab not working



  • Hi,

    I'm currently using QtCreator 3.1 and qt-everywhere-opensource-src-5.2.1 on Ubuntu 12.04
    My project is correctly working, i.e., i can build it and run without any trouble.

    But i've got some problems with the design tab inside Qtcreator.

    First, on all qml file (even with example projects), i have an error message "Using Qt Quick code model instead of Qt Quick2 (M324) (4:1)" and i can't use the design editor.

    Second, on qml files with other import than QtQuick 2.2 (for me QtQml.Models 2.1 and QtQuick.Controls 1.1), the import is underlined in red with the error message "QML module not found".
    I've tried to edit the .pro file by adding QML2_IMPORT_PATH=/home/user/qt-everywhere-opensource-src-5.2.1/qtquickcontrols/qml/QtQuick/Controls/ (also tried with QML_IMPORT_PATH), it doesn't work.
    Then, I tried to add it to my path in a terminal using "export QML_IMPORT_PATH=/home/user/qt-everywhere-opensource-src-5.2.1/qtquickcontrols/qml/QtQuick/Controls/" and this time, in the error message, i can see the added path in the error message, but it still doesn't work.

    Anyone has an idea to help me ?

    Thx !



  • For the imports to work properly and to get rid of M324, you need a properly configured project. Then the code model gets all the info it needs from the Qt you configured for your project.
    The code model will pick up the information from the qml directory of qtbase and parse the plugins.qmltype files.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.