[Solved]ReadyRead in not emmitting inside Window service



  • I am using QTcpsocket readyread() signal but it is not emmitting inside window service what could be the reason(s)?



  • Can you show some code?
    What is "window service"?



  • Hi,

    I guess you need to check in code whether the window service is belgon to QIODevice::Unbuffered 0x0020 Any buffer in the device is bypassed.
    mode, or any proxy will change the mode to this for your service while accessing Tcpsocket at any time.

    if yes then QTcpsocket cannot be opened and further things wont work.

    Thanks
    Prashant



  • Thanks for your reply
    Actually readyRead() is working fine on Console
    but by making my program as a service tcpsocket connects to the server and writes too. But readyread() is not emmitting.



  • somehow i solved my problem..



  • Hi,

    That's good, If you figure out what's the problem & what you did to solve then publish it here so all our Qt users will find helpfull in future.

    Thanks
    Prashant



  • Hii Prasant,,

    I am not using readyRead() inside services.
    I am using synchronous approach (Blocking) using waitForBytesWritten( int msecs ) So that i can get data from server inside service.



  • Ohh Okay that's fine then.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.