Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

SOLVED: qApp->exec(); not showing



  • Hi

    I have a class to build and show a widget.

    The last five lines of the class are
    @myBox.show();
    std::cout <<"3";
    qApp->exec();
    std::cout <<"4";
    return;@

    It outputs the "3" but not the "4" and the widge isn't shown.

    Am I missing something really obvious here?

    Cheers

    Sam



  • Hello Sam,

    Well I think it would be difficult to help you with just these 5 lines, you should give a more complete code so that people can help you here :)



  • Becouse you're block the app with exec(); post the complete code.



  • This is weird,

    I just went into my code to copy it so I could paste it here, and when I ran it everything worked???!!!! I didn't change anything.

    Obviously something strange with my IDE (I'm using NetBeans 7.0.1)
    I'm now going to download a different IDE. This is the second time something odd has happened, but not this dramatic.

    Thanks for looking anyway.

    Sam



  • Why don't you use the Qt IDE? :)


Log in to reply