Qt Dev Environment on a non-64-bit Mac



  • I am running a first-generation MacBook with a Core Duo processor on 10.6.6. Granted, it is a bit long in the tooth, but I'd like to hang onto it for another year or so.

    I've been trying to get squared away with using Qt Creator to dabble with Quick, but have run into some issues. In order for this to happen, I thought that I needed two components: Qt and Qt Creator. I have managed to get things running, but there are some rough edges that could be smoothed out.

    First off, the "Qt SDK":http://www.forum.nokia.com/info/sw.nokia.com/id/da8df288-e615-443d-be5c-00c8a72435f8/Qt_SDK.html is only compiled for 64-bit Macs. So that wasn't an option. I checked out the latest stable 4.7 branch from "gitorious":http://qt.gitorious.org/qt and compiled it. As far as I can tell, qmake works fine. Although, one error message I ran into stymied me for a few hours. After cloning the repository, no branch was flagged as active. The specific cryptic message I got was: @warning: remote HEAD refers to nonexistent ref, unable to checkout.@ After some sleuthing I discovered that entering a @git checkout 4.7.2@ allowed me to actually start the build process. ("Possible fix":http://support.github.com/discussions/repos/742-yet-another-remote-head-refers-to-nonexistent-ref I don't know if this link pertains to gitorious as well, but it seems to describe the problem accurately)

    When I checked out the latest 2.1 "Qt Creator":http://qt.gitorious.org/qt-creator, it built fine but there was no QmlDesigner plugin under the Qt Quick section. So entering the Design perspective was not an option. After digging around a little further, I discovered the "nightly snapshots of Qt Creator":ftp://ftp.trolltech.no/qtcreator/snapshots/ and downloaded a few builds of Qt Creator. Nearly every build I've downloaded works fine until I enter the design perspective. At which point the application hangs. Here is a sample error message logged when I click the design perspective:
    @ Dyld Error Message:
    Library not loaded: /Users/berlin/dev/dont_touch_its_nightly/qt/lib/QtDeclarative.framework/Versions/4/QtDeclarative
    Referenced from: /Volumes/Qt Creator/Qt Creator.app/Contents/MacOS/qmlpuppet.app/Contents/MacOS/qmlpuppet
    Reason: image not found@
    For what it's worth, there is no user account "berlin" on my machine. The only build of Qt Creator available on the trolltech ftp site that does not crash when I click the Design button is "ftp://ftp.trolltech.no/qtcreator/qt-creator-mac-opensource-2.1.0.dmg":ftp://ftp.trolltech.no/qtcreator/qt-creator-mac-opensource-2.1.0.dmg. (Note: I've only tested half a dozen; one of which was the 2011-03-01 one)

    Said another way, there are two things I'm interested in:

    1. Improve the initial buid procedures when using Qt sources (would be great if following the "Mac How-to":http://doc.qt.nokia.com/main-snapshot/install-mac.html worked)
      2a) Fix the nightly Qt Creator builds so that they don't crash because of a reference to something on the nightly build machine OR
      2b) Include the QmlDesigner by default plugin in the source so I can compile it myself.

    Thanks.



  • The Qt Creator release 2.1 is built as a universal binary, containing architectures i386 and x86_64 (i.e. 32bit and 64bit Intel, no PPC). So you should be fine with the prebuilt version.

    Regarding Qt libs itself, just download the source archive from the "download page":http://qt.nokia.com/downloads and compile for the architectures needed for your targets. Or use the prebuilt binaries of the libs only for Mac. They contain 32 bit versions in the universal binaries.

    I do not recommend compiling from the git sources unless you need some bugfixes which are not yet released or some bleeding edge features.



  • Thanks for the quick reply. I'm downloading the files you mentioned and will report back how it goes. I think that what you suggested will work for what I'm doing. However, the two issues I reported should still be addressed. Particularly 2a where the nightlies reference some inaccessible file.



  • That works.

    Have those downloads always been available? I started about a month ago to get set up and nothing I downloaded would install on my machine. It seems I just missed the obvious choices.

    Thanks again for your help.

    One final note regarding Qt Creator. The build you linked to is the same one from the trolltech ftp site that worked for me. All nightlies since mid-Feb (when 2.1.0 was released) error out when going to Design mode with a QML file open.



  • Yep, those downloads are available for a long time (and on that very same page).

    Yep, the 2.1 release build is from Feb-15 but was release just yesterday.

    The nightly builds differ in respect to quality of code (i.e. stability) and may not include all the platforms that are targeted in a release.

    For the QML error - did you consider to open a "bug report":http://bugreports.qt.nokia.com?



  • I guess it goes along with my lab rat status, but I wasn't aware of the correct place to file a bug report. Thanks again for pointing me in the right direction.



  • The DevNet status has nothing to do with the bug tracker. The logins are completely independent.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.