Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

The procedure entry point ?testBit@QBitArray@@QBE_NH@Z could not be located in the dynamic link library Qt5Core.dll



  • Hi,

    I migrated a Qt project from 5.0.2 to 5.2.1, both 32 Bit Windows with MingW. After compilation with MinWG4.8 in release mode I get the error from the title line when I start the program stand alone.

    I copied all the libraries (including Q5Core.dll) from the dir 'C:\Qt\Qt5.2.1\5.2.1\mingw48_32\bin', but it still doesn't work.

    Any help appreciated,
    Hans



  • welcome to devnet

    Did you do "rerun qmake" and a "rebuild"?



  • Thanks for the nice welcome.

    I did a 'mingw32-make clean', 'mingw32-make distclean', qmake and a rebuild.
    That didn't change anything.

    Hans


  • Moderators

    Hi,

    That message probably means that you are linking against the wrong version of the DLLs.

    Are you sure you are building your project with Qt 5.2.1?

    How many copies of MinGW do you have in your system?



  • Hi,

    I am sure that I have only Qt 5.2.1 installed. There is exactly one MinGW in the system, the one which came with Qt.

    I have exactly trhree Qt5Core.dll copies in my system. One is from the MinGW bin dir, One is in my installation dir of the project, a copy of the MinGW version. And one Qt5Core.dll in the Qt bin path. I tried this one too but this gives another entry point not found error (as expected).

    Hans


  • Moderators

    3 copies? That doesn't seem right.

    If you downloaded and installed "Qt 5.2.1 for Windows 32-bit (MinGW 4.8, OpenGL, 634 MB)", you should get TWO copied of Qt5Core.dll (the root path might be slightly different):

    C:\Qt\5.2.1\mingw48_32\bin\Qt5Core.dll

    C:\Qt\Tools\QtCreator\bin\Qt5Core.dll

    #1 is the one you use for your applications. #2 is for running Qt Creator only-- do NOT use this in your applications.

    How did you install/upgrade Qt? Can you list the full paths of all 3 copies of Qt5Core.dll?



  • Hi,

    I hve the two copies you mentioned and a third one in the deploy dir (a copy of C:\Qt\5.2.1\mingw48_32\bin\Qt5Core.dll) of the software I'm creating. That seems OK for me.

    Hans


  • Moderators

    Just to make sure, could you please open your C:\ drive in Windows Explorer and search for Qt5Core.dll?

    Do you get this error if you run your program from inside Qt Creator?

    Also, what version of Windows are you running?


Log in to reply