Add KDE libs permenatly



  • I just bought and configured a new laptop and installed all my apps but QT seems to be missing some libraries that I use heavily that were auto detected on my old machine and appeared in the tools pane. They are the libs for KDE development. I just can't figure out how to get these libs into QT for the life of me since my last install found them and automatically pulled them in and appear in the tools pane every time I open a new project. Mostly these tools are the widgets like LEDs/LCDs, KDE dialogs, graphs and such.

    This would be in the QT Designer interface.
    When I installed QT before I compiled it myself(from the download page) just as I did for this install but to no avail they weren't picked up this time.

    Any help to make this happen would be greatly appreciated.
    Oh and here's the system that I am using now.
    Toshiba Satellite C55T Intel core i3 processor 4GB of ram x86_64
    Arch Linux x64 KDE desktop as the OS

    My old system was a Toshiba Satellite L655, Intel core i5, 4GB of ram running 64 bit OS.
    The OS on this system was Arch Linux x64 KDE desktop just as on my new one.

    I have installed all of the same packages as before which includes all of the KDE Dev software.

    Again any help in fixing this would be greatly appreciated.
    Thanks in advance.



  • Have you installed kdesignerplugin?
    The widget plugins for Designer should be present in your {SDK}/plugins/designer folder (and probably are if you installed the system Qt Designer). If they are not in that folder then you can tell Qt to look other places by setting the QT_PLUGIN_PATH environment variable, e.g.
    @
    export QT_PLUGIN_PATH=/some/other/path/plugins
    @
    The plugins must match the version of Qt and compiler.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.