Module Cannot Be Found When Deploying Qt Application that Uses QtMobility Add-On



  • Hi,

    I'm experiencing a very similar issue to the one described here: http://lists.qt.nokia.com/pipermail/qt-qml/2010-August/000875.html.

    Essentially, I'm trying to deploy a QML Qt application I've developed to a Windows 7 device that does not have Qt installed. If I deploy a version of the application that does not use the QtMobility add-on, the application runs fine on the target device (I simply am copying over the application's .exe file along with all other required Qt DLLs). However, when I deploy a version of the application that does make use of the QtMobility add-on (I'm importing the QtMultimediaKit 1.1 module in a QML file), the application launches with a blank window with an error message stating "plugin cannot be loaded for module "QtMultimediaKit 1.1": The specified module could not be found."

    Does anyone have any helpful advice? I've tried running the Depends.exe helper program to determine DLL dependencies, but the dependencies seem to check out. I've tried copying every Qt DLL file I can find into the application's executing directory with no success. I'm at a point where I'm not sure what else I can try.



  • Anyone know how I can get the deployed application to not complain about the missing QtMultimediaKit module? I've tried placing the declarative_multimedia.dll file with the application's executable, but I still keep seeing the same error.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.