[SOLVED] QMAKE_INCDIR_OPENGL_ES2 / QMAKE_LIBDIR_OPENGL_ES2 / QMAKE_LIBS_OPENGL_ES2 について



  • ・私の開発環境です。
    ホスト:Windows7 32bit > VMware > ubuntu 12.04.2 LTS
    ターゲット:Wi-i.MX53

    Qt5.2.1 の組み込み環境を構築する為、下記よりソースコードを入手しました。

    http://download.qt-project.org/official_releases/qt/5.2/5.2.1/single/qt-everywhere-opensource-src-5.2.1.tar.gz

    付属の qtbase/mkspecs/devices/linux-imx53qsb-g++ のコメント欄を参考に下記のコンフィグコマンドを実行しました。
    すると、エラーが出ました。

    chung@ubuntu:~/qt-everywhere-opensource-src-5.2.1$ ./configure -prefix /usr/local/qt5-imx53 -release -device linux-imx53qsb-g++ -opensource -confirm-license -no-gtkstyle -device-option CROSS_COMPILE=/usr/local/DigiEL-5.9/x-tools/arm-cortex_a8-linux-gnueabi/bin/arm-cortex_a8-linux-gnueabi- -sysroot ~/sysroot -eglfs -no-pch -opengl es2 -no-xcb -silent

    • cd qtbase
    • /home/chung/qt-everywhere-opensource-src-5.2.1/qtbase/configure -top-level -prefix /usr/local/qt5-imx53 -release -device linux-imx53qsb-g++ -opensource -confirm-license -no-gtkstyle -device-option CROSS_COMPILE=/usr/local/DigiEL-5.9/x-tools/arm-cortex_a8-linux-gnueabi/bin/arm-cortex_a8-linux-gnueabi- -sysroot /home/chung/sysroot -eglfs -no-pch -opengl es2 -no-xcb -silent

    This is the Qt Open Source Edition.

    You are licensed to use this software under the terms of
    the Lesser GNU General Public License (LGPL) versions 2.1.

    You have already accepted the terms of the license.

    Creating qmake...
    Running configuration tests...
    Warning: Disabling pkg-config since PKG_CONFIG_LIBDIR is not set.
    Note: PKG_CONFIG_SYSROOT_DIR automatically set to /home/chung/sysroot

    Could not determine the target architecture!
    Turn on verbose messaging (-v) to see the final report.
    The OpenGL ES 2.0 functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR_OPENGL_ES2, QMAKE_LIBDIR_OPENGL_ES2 and QMAKE_LIBS_OPENGL_ES2 in
    /home/chung/qt-everywhere-opensource-src-5.2.1/qtbase/mkspecs/devices/linux-imx53qsb-g++.

    QMAKE_INCDIR_OPENGL_ES2, QMAKE_LIBDIR_OPENGL_ES2 and QMAKE_LIBS_OPENGL_ES2
    の環境変数の定義が必要なようです。

    gedit qtbase/mkspecs/devices/linux-imx53qsb-g++
    QMAKE_INCDIR_OPENGL_ES2=
    QMAKE_LIBDIR_OPENGL_ES2=
    QMAKE_LIBS_OPENGL_ES2=
    ここには、何(どこのディレクトリ)を指定すればよいのでしょうか?

    以上、よろしくお願いします。

    • (ハイフン) を使うと削除マークが付いてしまいます?


  • OpenGL/ES 込みの開発環境を使用していますか。

    通常は
    QMAKE_INCDIR_OPENGL_ES2: ターゲット用の GLES2/gl2.h があるディレクトリ
    QMAKE_LIBDIR_OPENGL_ES2: ターゲット用の libGLESv2.so があるディレクトリ
    QMAKE_LIBS_OPENGL_ES2: OpenGL/ES2 をリンクするときのオプション(-lGLESv2 -lEGL)
    を指定します。

    残念ながら、i.mx53用のそれらのファイルの入手方法については知らないです。



  • ありがとうございます。
    確認します。



  • GLES2/gl2.h / libGLESv2.so ですが、ターゲット用のコンパイラにありました。
    そのディレクトリを指定しましたが、同様のエラーが出ます。

    OpenGL/ES 込みの開発環境を使用していますか。
    ubuntu12.04 をインストールしただけで、OpenGL の環境を追加でインストールしていません。
    OpenGL/ES 込みの開発環境 を構築するには何をインストールすればよいでしょうか?

    sudo apt-get install freeglut3 freeglut3-dbg freeglut3-dev でしょうか?

    あと、
    qtbase/mkspecs/devices/TARGET/qmake.conf にある QT_SYSROOT は、
    export QT_SYSROOT= で指定するのでしょうか?
    それとも ./configure の -device-option QT_SYSROOT= で指定するのでしょうか?
    どこを指定するのでしょうか?

    以上、よろしくお願いします。



  • 済みません。パッケージ名はよく分からないです。

    ターゲット用の sysroot にあるのであれば指定をきちんとすれば問題ないはずです。
    sysroot は configure の -device-option で指定してください。



  • -sysroot にターゲットの rootfs を正しく指定しなければいけないんですね。
    できていませんでした。
    正しく指定する事で、エラーが消えました。

    ありがとうございました。


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.