Android 3rd party virtual keyboard not working with TextInput (Qt 5.2.1)



  • Hello,
    it seems that 3rd party virtual keyboards on android are not working properly when deploying a simple test app with Qt 5.2.1? I've tested with all items that can receive text input, always the same result (TextInput, TextEdit and even TextField and TextArea)
    I am using the "SwiftKey Keyboard":https://play.google.com/store/apps/details?id=com.touchtype.swiftkey on my android devices and I can only type 1 char and the next key press replaces the whole text (even if there is more than 1 char before I press a key), also when pressing the space key it appears a random key and no space, very weird.
    with the default android keyboard there are no problem as far as I am aware of, but 3rd party keyboards are widely used on android I think, so that might be a problem.

    Is that a known bug or am I missing something?

    when setting "inputMethodHints: Qt.ImhNoPredictiveText" it works better, I can type stuff but space is still not working and also I would like dictionary suggestions :)
    Since I don't have any other 3rd party keyboards I don't know if the problem is only with SwiftKey, but that is one of the best keyboards in the store.

    Code example:
    @
    import QtQuick 2.2

    Rectangle {
    width: 360
    height: 360

    TextInput {
        anchors.fill: parent
        font.pointSize: 20
        text: "type here"
        //inputMethodHints: Qt.ImhNoPredictiveText
    }
    

    }
    @

    also I get these warnings in the console output:
    W/IInputConnectionWrapper( 8703): getExtractedText on inactive InputConnection
    W/IInputConnectionWrapper( 8703): getTextBeforeCursor on inactive InputConnection
    W/IInputConnectionWrapper( 8703): getSelectedText on inactive InputConnection
    W/IInputConnectionWrapper( 8703): getTextAfterCursor on inactive InputConnection


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.