[SOLVED]No targets specified and no makefile found



  • Hello everyone, I need to compile QT in order to have the script patch for wkhtmltopdf.
    Well, I do as it follows here: http://code.google.com/p/wkhtmltopdf/wiki/compilation
    The problem is the step: make -j3 && make install, I can't do make cause can't find a makefile.
    I don't know if that has to do with the step before, configure, but I don't think so.
    Please I really need to have this done as soon as possible and that is getting on my nerves.
    I appreciate so much any help really !


  • Moderators

    Hi, and welcome to the Qt Dev Net!

    qmake generates the Makefile. Did you run the "qmake" step?



  • Hi! I can't do the step qmake-qt4 cause I haven't installed the QT yet, so.... unrecognized command.
    I have a folder named qmake under the wkhtmltopdf-qt folder I don't know if that has something to do for generating the makefile, but I don't know how! Thanks for the answer


  • Moderators

    So you're trying to build Qt yourself from their sources? Ok, ignore qmake since it doesn't exist yet.

    You need to configure successfully first. That will generate the Makefile.



  • I have to say that I haven't done this step:
    cat ../wkhtmltopdf/static_qt_conf_base ../wkhtmltopdf/static_qt_conf_linux | sed -re 's/#.*//'
    As I don't have the files static_qt_conf_base and static_qt_conf_linux, I can't do that, but I don't know if that step is necesary, I think the purpose is replacing the comments in those files for blanks, but I don't know why.
    So having that I'm skipping that step, how would I have to do the configure┬┐? I do just as follows....

    ./configure -nomake tools,examples,demos,docs,translations -opensource -prefix "../wkqt"

    I have also tried the script ./configure without parameters but still I don't generate the makefile....
    Thank you for your answers



  • Hi! It was a problem with the configure, Installing the package 'libxext-dev' solved the problem ;)


  • Moderators

    Great :) Happy coding!

    Please edit your original message and add "[SOLVED]" to the title.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.