Installing Qt-Components



  • Hi!

    I've been trying to install the qt-components for a while now, but I cannot get to work that on Windows.

    I've downloaded the project with git to C:\Qt\qt-components.
    I've got Qt SDK 1.1 TP in C:\QtSDK
    My PATH variable: C:\QtSDK\Desktop\Qt\4.7.1\mingw\bin
    My QTDIR variable: C:\QtSDK\Desktop\Qt\4.7.1
    Qt creator sees Qt in PATH so it should be okay, I guess. (I've also installed the latest Qt Creator snapshot in C:\Qt)

    But when I open the command prompt, navigate to the qt-components directory and type in configure, I'm getting this error:

    "Running qmake...
    ERROR: Unable to detect qmake. Set QTDIR=\path\to\qt and re-run configure.bat."

    How can I fix this? (I've searhed a lot, but I couldn't find the answer)



  • Update:

    Modificating the configure.bat, resolved the configuring problem,

    set QMAKE=C:\QtSDK\Desktop\Qt\4.7.1\mingw\bin\qmake
    ::if not "%QTDIR%" == "" set QMAKE=%QTDIR%\mingw\bin\qmake

    but got this after running qmake:

    WARNING: c:\QtSDK\Desktop\Qt\4.7.1\mingw\mkspecs\default\qmake.conf:108: Unescaped backslashes are deprecated.

    and found a "bugreport about this error":http://bugreports.qt.nokia.com/browse/QTSDK-432.

    Anyone has an idea how to make this done?



  • That warning is not fatal (but it is something to attend to). Basically, you should replace your backwards slashes by forward ones.



  • Did it, qmake:
    reading ... .pro
    ...
    reading ... .pro
    and then nothing...



  • Hm, now I have tried it on Ubuntu, both with making it from git, or the .deb from ppa:forumnokia/fn-ppa, as detailed in "Kate Alholas' blog":http://blogs.forum.nokia.com/blog/kate-alholas-forum-nokia-blog, getting this error for com.meego 1.0

    MRemoteThemeDaemon: Failed to connect to theme daemon (IPC)
    MAssembly: Stylesheet missing "/opt/qt4/share/themes/base/meegotouch/mardrone/style/mardrone.css"
    elements in cache: 172 , 0.357246 % filled cache
    MRemoteThemeDaemonClient: Failed to connect to theme daemon (IPC)
    No theme path is provided for MLocalThemeDaemonClient
    QObject: Cannot create children for a parent that is in a different thread.
    (Parent is DroneThread(0x12a6b80), parent's thread is QThread(0xef6c50), current thread is DroneThread(0x12a6b80)
    X Error: BadMatch (invalid parameter attributes) 8
    Extension: 153 (Uknown extension)
    Minor opcode: 30 (Unknown request)
    Resource id: 0x9a

    and this for com.nokia.symbian 1.0

    SymbianThemeBridgePlugin: Icon, Frame, Style and ImplicitSizeItem registered



  • A little late, but I had have a solution. I just had to correct my $QTDIR variable.

    After all, I had a similar problem on Ubuntu: I had have a qt path to opt/.. before my to QtSDK in my $PATH variable. After making the path to QtSDK and having a proper $QTDIR variable, it compiled like a charm, and the qt-components worked just fine :)
    (except the meego related stuff, because I haven't installed all the libraries for it)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.