Important: Please read the Qt Code of Conduct -

Qt platform plugin "xcb" error

  • Hi, I get this error when I execute program: This application failed to start because it could not find or load the Qt platform plugin "xcb".

    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, wayland-brcm, wayland-egl, wayland, xcb.

    Reinstalling the application may fix this problem.

    How to fix this issue? I have everything in folder what that program needed.
    Here is package:!2470

    Regards, Niko H.

  • Moderators


    How are you trying to deploy an application that you compiled yourself? If so, you are probably missing a shared library.

    Follow the quick-and-dirty guide here to find it: (it's written for Windows bus also works on Linux -- just replace *.dll files with *.so files)

  • Hi, All libraries is in the place. But I get still the error.

    Regards, Niko H.

  • Lifetime Qt Champion


    Do you have all dependencies properly installed on your target computer ? Check running ldd on the xcb plugin

  • Moderators

    [quote author="nikohal" date="1394956184"]Hi, All libraries is in the place.[/quote]Where are the libraries? Can you list the full path?

  • pi@raspberrypi ~/thc $ ls platforms (folder)

  • [quote author="SGaist" date="1395005501"]Hi,

    Do you have all dependencies properly installed on your target computer ? Check running ldd on the xcb plugin[/quote]

    pi@raspberrypi ~/thc/platforms $ ldd
    /usr/lib/arm-linux-gnueabihf/ (0xb6f38000) => /lib/arm-linux-gnueabihf/ (0xb6f1d000) => /usr/lib/arm-linux-gnueabihf/ (0xb6e09000) => /usr/lib/arm-linux-gnueabihf/ (0xb6e00000) => /usr/lib/arm-linux-gnueabihf/ (0xb6dec000) => /usr/lib/arm-linux-gnueabihf/ (0xb6de1000) => /usr/lib/arm-linux-gnueabihf/ (0xb6dd2000) => /usr/lib/arm-linux-gnueabihf/ (0xb6db3000) => /usr/lib/arm-linux-gnueabihf/ (0xb6da7000) => /usr/lib/arm-linux-gnueabihf/ (0xb6d9a000) => /usr/lib/arm-linux-gnueabihf/ (0xb6d8d000) => /usr/lib/arm-linux-gnueabihf/ (0xb6d80000) => /usr/lib/arm-linux-gnueabihf/ (0xb6d75000) => /usr/lib/arm-linux-gnueabihf/ (0xb6d65000) => /usr/lib/arm-linux-gnueabihf/ (0xb6d5a000) => /usr/lib/arm-linux-gnueabihf/ (0xb6d4e000) => not found => /usr/lib/arm-linux-gnueabihf/ (0xb6d19000) => /usr/lib/arm-linux-gnueabihf/ (0xb6c97000) => /lib/arm-linux-gnueabihf/ (0xb6bb2000) => /opt/vc/lib/ (0xb6b7f000) => not found => not found => not found => /lib/arm-linux-gnueabihf/ (0xb6b60000) => /usr/lib/arm-linux-gnueabihf/ (0xb6a92000) => /lib/arm-linux-gnueabihf/ (0xb6a21000) => /lib/arm-linux-gnueabihf/ (0xb69f9000) => /lib/arm-linux-gnueabihf/ (0xb68ca000)
    /lib/ (0xb6fcd000) => /usr/lib/arm-linux-gnueabihf/ (0xb68b4000) => /usr/lib/arm-linux-gnueabihf/ (0xb68a9000) => /usr/lib/arm-linux-gnueabihf/ (0xb689d000) => /usr/lib/arm-linux-gnueabihf/ (0xb6890000) => /lib/arm-linux-gnueabihf/ (0xb6872000) => /lib/arm-linux-gnueabihf/ (0xb6849000) => /lib/arm-linux-gnueabihf/ (0xb6807000) => /lib/arm-linux-gnueabihf/ (0xb67f8000) => /opt/vc/lib/ (0xb67ea000) => /opt/vc/lib/ (0xb67d8000) => /opt/vc/lib/ (0xb67be000)

  • Moderators


    [quote author="nikohal" date="1395054352"] => not found
    [/quote]This is probably the root cause of your problem. Check your XKB installation. If that still doesn't fix things, continue below.

    [quote author="nikohal" date="1395054352"] => not found => not found => not found
    [/quote]export LD_LIBRARY_PATH, then run ldd again.

    [quote author="nikohal" date="1395054273"]pi@raspberrypi ~/thc $ ls platforms (folder)
    [/quote]That's not all the libraries. The guide says copy EVERYTHING.

  • Hi,
    How I do install this dependence libxkbcommon?

    Regards, Niko H.

  • Hi,
    I found how to install libxkbcommon. But now I get next error:
    Linux system - locale: "English"
    Cant find EGLConfig, returning null config
    Unable to find an X11 visual which matches EGL config 0
    QXcbConnection: XCB error: 165 (Unknown), sequence: 149, resource id: 0, major code: 149 (Unknown), minor code: 20

    How fix this?

    Regards, Niko H.

  • Moderators

    I don't know, sorry. It looks like an issue with your Linux filesystem, not just Qt -- I think you'll have better luck if ask devs who have Raspberry Pi experience. See

    EDIT: You can reach people in the "Qt on Pi" project at

  • I'm sorry but I'm receiving the same error when I try to launch the qtcreator ide. I have just installed the qt 5 but I can't launch qtcreator for the same reason. Any ideas?

  • You need install dependencies in raspberry pi: sudo apt-get install libdrm-nouveau1a libegl1-mesa-drivers libgbm1 libopenvg1-mesa libxcb-dri2-0 libxcb-image0 libxcb-icccm4 libxcb-sync0 libxcb-keysyms1 libxcb-render-util0 libxcb-randr0

  • I've tried on installing the dependencies you have suggested installing using the apt-get command. Unfortunately that doesn't work. I'm not using raspbian at the moment, I'm trying to install the qt5 onto my ubuntu 10. I've read it is possible to develop App on ubuntu and after compilation move it to the raspbian using the cross-compiling technique.

  • Check your dependencies with command ldd program_name

  • ok... now I receive an error when I try to launch qtcreator... it seems the "" is missing! How can I check if it is properly installed? What do I have to do to install it?

  • I have tried on installing Qt5 from git repository, I have followed the instruction guide described "here": and and when I make Qt using the command "make -j4 all" (I have tried both the command) I received the error bellow:

    @collect2: ld returned 1 exit status
    make[6]: *** [../../../../plugins/platforms/] Error 1
    make[6]: Leaving directory /root/opt/qt5/qtbase/src/plugins/platforms/xcb' make[5]: *** [sub-xcb-plugin-pro-all-ordered] Error 2 make[5]: Leaving directory/root/opt/qt5/qtbase/src/plugins/platforms/xcb'
    make[4]: *** [sub-xcb-all] Error 2
    make[4]: Leaving directory /root/opt/qt5/qtbase/src/plugins/platforms' make[3]: *** [sub-platforms-all] Error 2 make[3]: Leaving directory/root/opt/qt5/qtbase/src/plugins'
    make[2]: *** [sub-plugins-all] Error 2
    make[2]: Leaving directory /root/opt/qt5/qtbase/src' make[1]: *** [sub-src-all] Error 2 make[1]: Leaving directory/root/opt/qt5/qtbase'
    make: *** [module-qtbase-all] Error 2@

    now I really need a help. I have tried all the suggested ways to install qt5 without success.... Why? Is it so difficult to install it?

  • Ok, I have installed evrything again and it has started working well. Thank you anyway.

Log in to reply