[SOLVED] Qt on Slackware Linux



  • hi,

    Standard Pre-Installed Qt4.8. is working with the Qt Creator 2.8.0, which I got from http://slackbuilds.org/repository/14.1/development/qt-creator/

    Somehow, when removed the old Qt4.8 and try to get this QtCreator working with the new Qt5.2.1
    http://slackbuilds.org/repository/14.1/libraries/qt5/
    it says no qmake found.

    I only can find a qmake-qt5 but no qmake.
    It's possible ,that Qt5.2.1 only provides the qmake-qt5, but how is it possible to get this working with my QtCreator?



  • qmake-qt5 is a regular qmake that was renamed by a package maintainer to avoid collisions with qt4.

    I would suggest you to use Qt from "qt-project downloads":http://qt-project.org/downloads
    In this case you will get Qtcreator and Qt framework.
    The installer will put everything under one directory which you can change during installation. By default it is $HOME/Qt5.2.1

    If you prefer to keep the Qt5 package and removed qt4 then rename qmake-qt5 to qmake



  • using the qt-installer and it's .run file, solved my problem :) thank you

    compiler is doing fine, but it shows a few errors:

    libGL error: failed to load driver: i965
    libGL error: Try again with LIBGL_DEBUG=verbose for more details.

    any solution for this ?



  • btw: the error only appears with a QT GUI project
    console application works fine



  • Qt tries to use opengl and looks like your video setup does not have it.
    Check what LIBGL_DEBUG tells.
    Maybe you will need to update video drivers and or install mesa libraries.
    I have not seen this problem on my linux boxes (fedora and ubuntu) so I can not tell much here.



  • oh, i'm working on a hp workstation here, could be the reason for this error, because it has no graphic card(just intel xeon integraded graphics) which normally provides opengl.



  • It can be the reason.

    • Do you use opengl in your application? If so, then you may need to install mesa libraries and use software opengl.
    • What messages LIBGL_DEBUG=verbose gives ?
    • Does qtcreator from downloaded Qt gives the same error?
    • If you try to build Qt examples do they provide the same error?


  • Actually i don't need OpenGL on this pc,
    the error message just appears(application output) in a GUI(mainwindow etc.) project when I compile it, but the application itself works fine.

    the console application works perfectly.



  • Just out of curiosity. If you will set LIBGL_DEBUG=verbose before a compilation then maybe you will see who is the reason for the message.
    something like this
    @
    export LIBGL_DEBUG=verbose
    qmake
    make
    @



  • sry for the question, but where you want me to write this down?



  • Run these commands in a shell command prompt.

    Run it in separate directory from your project directory.
    For example if your .pro file is located in
    /home/user/workspace/myproject
    then
    @
    cd /home/user/workspace/
    mkdir build-myproject
    cd build-myproject
    export LIBGL_DEBUG=verbose
    qmake -recursive ../myproj
    make
    @



  • it says: bash: qmake-recursive: command not found



  • There is a space between qmake and -recursive



  • it says: qmake command not found,
    also can't find a qmake or qmake-qt5 with

    which qmake

    or

    which qmake-qt5

    btw: i used the online installer straight from the qt website(.run)



  • The try to run qmake with full path.
    Let say you have Qt installed in /home/user/Qt5.2.1
    then run it
    @
    /home/user/Qt5.2.1/5.2.1/gcc/bin/qmake
    @



  • thats the output in the terminal:
    @
    bash-4.2$ make
    /home/reidom1994/Qt/5.2.1/gcc_64/bin/uic ../GUI_Hello_World/mainwindow.ui -o ui_mainwindow.h
    g++ -c -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../../Qt/5.2.1/gcc_64/mkspecs/linux-g++ -I../GUI_Hello_World -I../../Qt/5.2.1/gcc_64/include -I../../Qt/5.2.1/gcc_64/include/QtWidgets -I../../Qt/5.2.1/gcc_64/include/QtGui -I../../Qt/5.2.1/gcc_64/include/QtCore -I. -I. -I. -o main.o ../GUI_Hello_World/main.cpp
    g++ -c -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../../Qt/5.2.1/gcc_64/mkspecs/linux-g++ -I../GUI_Hello_World -I../../Qt/5.2.1/gcc_64/include -I../../Qt/5.2.1/gcc_64/include/QtWidgets -I../../Qt/5.2.1/gcc_64/include/QtGui -I../../Qt/5.2.1/gcc_64/include/QtCore -I. -I. -I. -o mainwindow.o ../GUI_Hello_World/mainwindow.cpp
    /home/reidom1994/Qt/5.2.1/gcc_64/bin/moc -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../../Qt/5.2.1/gcc_64/mkspecs/linux-g++ -I../GUI_Hello_World -I../../Qt/5.2.1/gcc_64/include -I../../Qt/5.2.1/gcc_64/include/QtWidgets -I../../Qt/5.2.1/gcc_64/include/QtGui -I../../Qt/5.2.1/gcc_64/include/QtCore -I. -I. -I. ../GUI_Hello_World/mainwindow.h -o moc_mainwindow.cpp
    g++ -c -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../../Qt/5.2.1/gcc_64/mkspecs/linux-g++ -I../GUI_Hello_World -I../../Qt/5.2.1/gcc_64/include -I../../Qt/5.2.1/gcc_64/include/QtWidgets -I../../Qt/5.2.1/gcc_64/include/QtGui -I../../Qt/5.2.1/gcc_64/include/QtCore -I. -I. -I. -o moc_mainwindow.o moc_mainwindow.cpp
    g++ -Wl,-O1 -Wl,-rpath,/home/reidom1994/Qt/5.2.1/gcc_64 -Wl,-rpath,/home/reidom1994/Qt/5.2.1/gcc_64/lib -o GUI_Hello_World main.o mainwindow.o moc_mainwindow.o -L/home/reidom1994/Qt/5.2.1/gcc_64/lib -lQt5Widgets -lQt5Gui -lQt5Core -lGL -lpthread @



  • I don't see any error message in the output.
    Does it mean that issue is gone ?
    Does your app works without any error messages ?



  • It still appears in the application output :
    Starting /home/user/QT C++/myproject/myproject...
    libGL error: failed to load driver: i965
    libGL error: Try again with LIBGL_DEBUG=verbose for more details.

    Application still works fine.

    I have no idea, but it's working so doesn't matter i think xD



  • What if you will run your app with LIBGL_DEBUG=verbose
    something like
    @
    export LIBGL_DEBUG=verbose
    /home/user/QT C++/myproject/myproject…
    @

    If it does not bother you then you can run your app and redirect all output to /dev/null
    @
    /home/user/QT C++/myproject/myproject… > /dev/null 2>&1
    @



  • first one without root:

    libGL: OpenDriver: trying /usr/lib64/xorg/modules/dri/i965_dri.so
    libGL error: failed to open drm device: Permission denied
    libGL error: failed to load driver: i965
    libGL: OpenDriver: trying /usr/lib64/xorg/modules/dri/swrast_dri.so

    with root:
    Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
    libGL: OpenDriver: trying /usr/lib64/xorg/modules/dri/i965_dri.so
    libGL: Can't open configuration file /root/.drirc: No such file or directory.

    I also tried the second one.
    Whats the reason, to redirect the output to /dev/null ^^



  • About /dev/null.
    It will hide your error messages and you will not worry about it. :-)

    Some GNU/Linuxes have a "video" group and only members of that group are allowed to use opengl.
    Could you check if Slackware has such restriction. If so then add your self to that video group re-login and try to run your app again.



  • i just added my self with $usermod -aG video <username>
    -> in /etc/group its says video:x:18:

    but same error still appears.



  • do you see the same error if you run "glxinfo":http://dri.freedesktop.org/wiki/glxinfo/ or glxgears
    @
    glxinfo
    glxgears
    @



  • under normal user: for both
    libGL error: failed to load driver: i965
    libGL error: Try again with LIBGL_DEBUG=verbose for more details.

    under root:

    its seems to run without errors.



  • what does the following commands show
    @
    id
    ls -l /dev/dri
    @



  • I'll try it on monday when i'm on my workstation pc again :)



  • bash-4.2$ id
    uid=1000(username) gid=100(users) groups=100(users),18(video)

    bash-4.2$ ls -l /dev/dri
    total 0
    crw-rw---- 1 root video 226, 0 Mar 24 08:32 card0
    crw-rw---- 1 root video 226, 64 Mar 24 08:32 controlD64



  • I'm running out of ideas :-)
    Maybe this last one

    Do you have Mesa libraries installed?
    What ldd on your app shows?
    @
    ldd yourapp | grep libGL
    @

    And one more.
    When you start qtcreator does it show the same error as your app?
    If you build any Qt examples and start them do they show the same error?



  • bash-4.2$ ldd myapp | grep libGL
    libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007f79fab6b000)

    somehow i get no error anymore, lol.
    (i started the same project)

    I also started an OpenGL example. no errors.
    :)

    idk what happened.



  • Glad to hear that issue is resolved.



  • thank you ! :)



  • Could you put [SOLVED] in front of the title of your initial post.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.