Qt5.2.1, Visual Studio 10: Webkit not built?



  • I'm attempting to build Qt 5.2.1 from the source zip, including webkit on windows 8.1, 64-bit using Visual Studio 10.

    In the makefile generate by configure I can clearly see that module-qtwebkit is scheduled to be built and the build seems successful, yet I can't find the webkit dll anywhere (neither does cmake, and as my project needs webkit it's crucial I get this to work).
    I tried building it separately by invoking "nmake qtwebkit" resulting only in the message "‘qtwebkit’ is up to date"

    Any ideas as to what's going wrong?


  • Moderators

    Hi,

    Have you double-checked that you have all of Qt WebKit's dependencies? See http://qt-project.org/wiki/Building_Qt_5_from_Git



  • I'm not building from git, I'm building from the source zip that can be downloaded from digia. That'sanother problem: all documentation seems to assume one builds from git and half of the info provided is irrelevant for my situation (if only I knew which half...).

    I didn't have python installed when I first tried and got quite a clear error about that. I would expect that if anything else is missing the build should fail with an error and not skip an entire module silently.


  • Moderators

    The list of requirements/dependencies is the same, regardless of whether you're building from git or a zip file. The build steps are the same too ("configure", then "make", then "make install").

    Please post the following for diagnostic purposes:

    Your configure options

    qtbase\config.summary



  • Not entirely: I don't need git for starters and it's unclear whether I need all or part of the other requirements in the same list.
    As the build phase fails to give me an error when a required dependency is missing I apparently have no other choice than to install software until the build phase actually seems to build something.

    I'll be filing a bug report later today for the lack of an error when not all build requirements are satisfied.



  • configure options:

    configure -opensource -debug-and-release -opengl desktop -nomake examples -nomake tests -skip qtwebkit-examples -confirm-license

    config.summary:
    Environment:
    INCLUDE=
    c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\INCLUDE
    c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\ATLMFC\INCLUDE
    C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\include

    LIB=
      c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\LIB\amd64
      c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\ATLMFC\LIB\amd64
      C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\lib\x64
      
    PATH=
      c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\BIN\amd64
      c:\Windows\Microsoft.NET\Framework64\v4.0.30319
      c:\Windows\Microsoft.NET\Framework64\v3.5
      c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\VCPackages
      c:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE
      c:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools
      C:\Program Files (x86)\HTML Help Workshop
      C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\bin\NETFX 4.0 Tools\x64
      C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\bin\x64
      C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\bin
      C:\WINDOWS\system32
      C:\WINDOWS
      C:\WINDOWS\System32\Wbem
      C:\WINDOWS\System32\WindowsPowerShell\v1.0\
      C:\Program Files\Perforce
      c:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\
      c:\Program Files\Microsoft SQL Server\100\Tools\Binn\
      c:\Program Files\Microsoft SQL Server\100\DTS\Binn\
      C:\Program Files (x86)\CMake 2.8\bin
      C:\Program Files (x86)\Scrivener
    

    Configuration:
    pcre
    debug
    compile_examples
    Qt Configuration:
    minimal-config
    small-config
    medium-config
    large-config
    full-config
    debug_and_release build_all release
    debug
    shared
    zlib
    png
    freetype
    build_all
    accessibility
    opengl
    audio-backend
    wmf-backend
    native-gestures
    qpa
    concurrent

    QMAKESPEC...................win32-msvc2010 (detected)
    Architecture................x86_64, features: sse sse2
    Host Architecture...........x86_64, features: sse sse2
    Maketool....................nmake
    Debug build.................yes (combined)
    Default build...............debug
    Force debug info............no
    C++11 support...............auto
    Link Time Code Generation...no
    Accessibility support.......yes
    RTTI support................yes
    SSE2 support................yes
    SSE3 support................yes
    SSSE3 support...............yes
    SSE4.1 support..............yes
    SSE4.2 support..............yes
    AVX support.................yes
    AVX2 support................no
    NEON support................no
    IWMMXT support..............no
    OpenGL support..............yes
    Large File support..........yes
    NIS support.................no
    Iconv support...............no
    Inotify support.............no
    eventfd(7) support..........no
    Glib support................no
    CUPS support................no
    OpenVG support..............no
    OpenSSL support.............no
    Qt D-Bus support............no
    Qt Widgets module support...yes
    Qt GUI module support.......yes
    QML debugging...............yes
    DirectWrite support.........no
    Use system proxies..........no

    Third Party Libraries:
    ZLIB support............qt
    GIF support.............plugin
    JPEG support............plugin
    PNG support.............yes
    FreeType support........yes
    Fontconfig support......no
    HarfBuzz-NG support.....no
    PCRE support............qt
    ICU support.............no
    ANGLE...................no

    Styles:
    Windows.................yes
    Windows XP..............yes
    Windows Vista...........yes
    Fusion..................yes
    Windows CE..............no
    Windows Mobile..........no

    Sql Drivers:
    ODBC....................no
    MySQL...................no
    OCI.....................no
    PostgreSQL..............no
    TDS.....................no
    DB2.....................no
    SQLite..................plugin (qt)
    SQLite2.................no
    InterBase...............no

    Sources are in..............C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase
    Build is done in............C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase
    Install prefix..............C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase
    Headers installed to........C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\include
    Libraries installed to......C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\lib
    Arch-dep. data to...........C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase
    Plugins installed to........C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\plugins
    Library execs installed to..C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\bin
    QML1 imports installed to...C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\imports
    QML2 imports installed to...C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\qml
    Binaries installed to.......C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\bin
    Arch-indep. data to.........C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase
    Docs installed to...........C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\doc
    Translations installed to...C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\translations
    Examples installed to.......C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\examples
    Tests installed to..........C:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\tests

    Note: I shortened the file paths for readability



  • As it's supposedly required, I tried building icu but the configuration seems to fail.
    I get some cygwin warnings ( couldn't compute FAST_CWD pointer) and the usual MS_DOS style path detected, then the following:

    export CPP= CC=cl CXX=cl CPPFLAGS= CFLAGS= /Gy /MD CXXFLAGS= /Gy /MD LDFLAGS= MAKE=
    Running ./configure --prefix=/cygdrive/c/icu/dist for Windows with Cygwin using Microsoft Visual C++ compiler

    and finally the following error:

    runConfigureICU: line 424: c:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\configure.bat: command not found
    runConfigureICU: ./configure failed


  • Moderators

    Good point.

    Here is the official, non-git documentation: http://qt-project.org/doc/qt-5/windows-requirements.html

    Yes, ICU is definitely required for Qt WebKit. There is a pre-built package available for MSVC2010: http://qt-project.org/wiki/Compiling-ICU-with-MSVC



  • [quote author="JKSH" date="1394457481"]Good point.

    Here is the official, non-git documentation: http://qt-project.org/doc/qt-5/windows-requirements.html

    Yes, ICU is definitely required for Qt WebKit. There is a pre-built package available for MSVC2010: http://qt-project.org/wiki/Compiling-ICU-with-MSVC[/quote]

    Thanks for the info. As I have experienced application crashes because of dll's built with different options than the main application, I prefer to build it from source rather than using the precompiled dll (which, unfortunately, doesn't seem to be working either for the moment)



  • bq. runConfigureICU: line 424: c:\Development[ snip ]\qt-everywhere-opensource-src\qtbase\configure.bat: command not found
    runConfigureICU: ./configure failed

    Something is horribly wrong here, why does runConfigureICU (part of the icu dist) is trying to configure Qt (qtbase\configure.bat)?

    bq. Running ./configure —prefix=/cygdrive/c/icu/dist for Windows with Cygwin using Microsoft Visual C++ compiler

    Don't do that. Use the "VS20XX Native Tools Command prompt". Make sure that cygwin is not in your PATH. Make sure that Win32 versions of Perl, Python and Ruby are accessible. Make sure that icu/bin and Qt-5.2.1/gnuwin32/bin are also in your PATH. INCLUDE and LIB environment variables should also be set to find icu installation.

    Use configure.bat with a DOS path for prefix.

    Personnaly, I had problems with nmake but success with jom.exe (!?)

    I built Qt5.1/Qt5.2 with VS2010, VS2012 and VS2013 successfully on Win7/Win8 machines with this setup.



  • [quote author="sandy.martel" date="1394491314"]
    I built Qt5.1/Qt5.2 with VS2010, VS2012 and VS2013 successfully on Win7/Win8 machines with this setup.[/quote]

    Did you successfully build Qt with web kit as static library?
    I am having troubles to build ICU as static lib in MSVC12(2013) x64 with the error "C compiler not found", while x86 works well..
    (I hope not too much OT..)



  • I definitely have WebKit, our UI is html based. But sorry, I never tried to build as a static library.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.