Running QML application package



  • Hi all,
    I have created a QML application for running Qt 5.2 controls. The main programme uses QQMLEngine for loading the QML file. It is running good when I run it on QtCreator, but fails to run when I run it in separate folder. Please help to solve this. Do I need to add more dependencies.

    Ansif



  • Hey,

    • Which error occures?
    • Have you tried to start it from console and check for output?
    • Have you checked if your QML-file exists and is in the right folder?


  • Hi onek24,

    I am using QQmlApplicationEngine for loading the main.qml file. It will work if i run it in Qt creator. But when i copy the exe to the Qt bin folder and run it from there, then it fails.
    Is QQmlApplicationEngine working well ?
    Ansif



  • Well, QQmlApplicationEngine was introduced in Qt 5.1 and is still a finely useable component. If you are missing some dll's it would output that, so the dependencies shouldn't be a problem.
    And what do you mean by "it fails", does it start but doesn't display something or doesn't it even start?



  • sorry for the late reply. It was my mistake, hence QQMLApplicationEngine is working fine. There was my own 3rd party dll missing in my system.
    I refer it properly in the QML application and it works fine.

    Anyway thank you for your nice help. Please keep in touch.

    Ansif



  • You're welcome, i'm glad that you could solve your problem.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.