Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Project ERROR: Unknown module(s) in QT: quick-private



  • hi guys

    i'm trying to compile Qt 5.2.1 from sources on Rhel 6.3 Santiago. I have the following error with make :

    bq. Project ERROR: Unknown module(s) in QT: quick-private

    The configure options I use are:

    bq. ./configure -developer-build -confirm-license -opensource -no-opengl -nomake examples -no-dbus -qt-xcb -no-dbus

    Any ideas ?

    Thanks



  • as faar i know QT Quick need open-gl on Linux

    try to build with GL



  • hi,

    I tried with GL enabled but it's still the same :(

    bq. ./configure -developer-build -confirm-license -opensource -nomake examples -no-dbus -qt-xcb


  • Moderators

    Add:
    @
    -skip qtquick1 -skip declarative
    @



  • Thanks !

    Actually I tried:

    bq. -nomake tests

    and that seemed to work. I think it goes in the same direction as your solution, but maybe it omits a larger sets of modules.

    Now i will try to compile Qt Creator and see what happens.



  • So ... Now, when i install Qt-Creator 3.0.1, I have the following error :

    bq. Project ERROR: Unknown module(s) in QT: script

    :((

    Anyone knows what's it might be related to ?



  • up

    anyone encountered this ?



  • I have the same issue.

    tried to build 5.3 alpha under ubuntu 13.10

    I'm using a 2011 mac mini, the nvidia driver doesn't install gl headers, so I'm building qt without opengl.


  • Moderators

    [quote author="billconan" date="1394897072"]I have the same issue.

    tried to build 5.3 alpha under ubuntu 13.10

    I'm using a 2011 mac mini, the nvidia driver doesn't install gl headers, so I'm building qt without opengl.[/quote]

    Install mesa, then the nVidia driver. It should work. For detailed info, please visit the wiki page called 'Building Qt5 from git'.



  • I kinda think this is qt config bug. I don't really need opengl. Qt configure should disable that module for me.


Log in to reply