Solved: QtCreator Toolchain mismatch



  • I am trying to start to understand how to build a UI application for the beaglebone black.

    I downloaded the following toolchain:

    angstrom-2011.03-x86_64-linux-armv7a-linux-gnueabi-toolchain-qte-4.6.3.tar.bz2

    I installed the following QtCreator:

    qt-opensource-linux-x64-1.05.01-online.run

    I run /usr/local/angstrom/qrm/environment-setup before I start QtCreator. I can see the environment variables in term. I have tried to setup a kit to use the angstrom compiler from the toolchain, but my project keeps telling me that I need a compiler. Is this because the toolchain is not compatible with the version of QtCreator. In the help->about for QtCreator it is 4.6.1 with GCC 4.6.1 or am I just stumbling around trying to setup the kit correctly.



  • I'm not sure if I am any closer, but when I try to compile the example I get this error message.
    For some reason it seems to be looking for the wrong compiler. I have created a kit with the compiler I want to use and made it the default.

    DQT_GUI_LIB -DQT_CORE_LIB -I../../../../5.2.1/gcc_64/mkspecs/linux-g++ -I../qtprojects -I../../../../5.2.1/gcc_64/include -I../../../../5.2.1/gcc_64/include/QtWidgets -I../../../../5.2.1/gcc_64/include/QtGui -I../../../../5.2.1/gcc_64/include/QtCore -I. -I. -I. -o main.o ../qtprojects/main.cpp
    make: g++: Command not found
    make: Leaving directory `/home/ray/Qt/Tools/QtCreator/bin/build-qtprojects-Desktop_Qt_5_2_1_GCC_64bit-Release'
    make: *** [main.o] Error 127
    21:26:44: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project qtprojects (kit: Desktop Qt 5.2.1 GCC 64bit)
    When executing step 'Make'
    21:26:44: Elapsed time: 00:01.



  • I think this is your biggest clue:

    bq. Error while building/deploying project qtprojects (kit: Desktop Qt 5.2.1 GCC 64bit)

    That does not look like the name of a kit that would cross compile.

    Make sure you have the correct kit selected as your build configuration in the Project settings



  • I saw that and I have a different kit set as the default. I can't seem to figure out how to assign the kit to my project. At this point it seems like magic. I can't even find where to tell it it is for a different platform.

    When I open the project build selector, it will let me choose the build, but not the other aspects.



  • I created a new kit:

    Name: arm-angstrom
    Device Type: Generic Linux Type // not too many choices here
    Device: Generic Linux Device (default for Generic Linux)
    Sysroot: who knows
    Compiler GCC
    Debugger: System GDB /usr/bin/gdb // link to angstrom debugger
    Qt version: Qt 5.2.1 GCC 64 bit
    Qt mkspwc: linux-arm-gnueabi-g++

    The compiler

    Name: GCC
    Compiler path: /usr/local/angstrom/arm/bin/arm-angstrom-linux-gnueabi-9++
    Platform codegen: who knows
    Platform linker: Who knows
    ABI: Custom arm linux generic elf 64bit

    Devices
    Name Generic Linux Device
    Machine Type: Physical Device
    Hostname: 192.168.7.1 ssh port: 22

    Tested and verified
    The project run key selector still thinks its a local even when the kit points to the remote device?

    Should I be asking this question somewhere else?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.