Qt Creator not using Qt 5.2.0 with 5.1.0 installed



  • I am upgrading Qt to get access to QtQuick.Controls 1.1. I have both Qt 5.2.0 and 5.1.0 installed and I can't seem to get QtCreator to use version 5.2.0.

    Qt 5.2.0 is auto-detected in the Kits and Qt Versions and I set Qt 5.2.0 to the default. Qt 5.1.0 shows up in the manual section. When I run the program though, the creator is still using 5.1.0. I tried removing Qt 5.1.0 from the kits and versions and then Run becomes disabled. I think I am missing something that may be obvious.

    If I uninstall Qt 5.1.0, Creator starts using 5.2.0 properly, but I need to have 5.1.0 installed on the system for another project so this isn't a optimal workaround. Any thoughts as to what the problem could be?

    Qt Creator 3.0.0
    Qt 2.5.0 & 2.1.0
    gcc 4.6.3


  • Moderators

    welcome to devnet

    What OS are you using?

    Just to be that you know about it. You can change the tool chain and the Qt lib version in the "Projects-->Buuild&Run" menu tab. You can add different kits for the project. Changing to a different kit is possible too.

    Did you do the compilation yourself? The gcc you are referring to is fairly "old". I have just checked that I am using the pre-build linux version of 5.2.1 with gcc 4.8.1 (Ubuntu). The windows pre-build of 5.1.0 uses also a gcc 4.8 version.



  • I'm using Ubuntu 12.04.04 LTS. I tried setting the default kit in Projects->build&Run, but it doesn't seem to use 5.2.0 unless 5.1.0 has been completely removed from the system.


  • Moderators

    I have Ubuntu 13.10. At first I installed Qt 5.2.0 pre-build with creator. Later I have added Qt 4.8.5 for a cross compile.
    After adding and managing the tool chain and Qt libs I can simply switch between different kits under "Projects--> Build&Run". All the different kits I had added for the specific project are listed right of the "Add Kits" combobox.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.