Qt Creator "dependent "xxxx.cpp" does not exist."



  • Hi,
    I am trying to compile a big project but my Qt Creator(3.0.0) instance is not finding the some files of the
    project while the previous versions worked just fine for the project.The issue pannel is throwing this error:

    @
    dependent "xxxx.cpp" does not exist.
    @

    I know this error is obvious but i double checked the file is in the proper location and my previous qt 4.8.1 setup with with Qt Creator 2.4.1 could build the project fine.

    Is there something specific on this version of Qt Creator that I am missing , or is it a good thing to try and use an old version of Qt Creator with the latest Qt libraries? Any help will be appreciated.
    Thanks.


  • Moderators

    You need Qt Creator 3.x to work with Qt 5.2, sorry. Qt changed a bit and we needed to adapt to those changes.

    Does this work when calling the relevant commands (qmake/make) on the command line? If that is the case, then it is a bug in Qt Creator. Otherwise it is a problem with the build system used.

    Is that dependent file in the shadow build or in the source directory? Some .pro-files managed to break shadow builds, so maybe you can try with a in-source build (and then fix the .pro-file if that is indeed the case!).



  • You should try to add :

     @ $$PWD/xxxx.xcpp@
    

    in front of the files you need, exemple :

    @SOURCES +=
    $$PWD/code/main.cpp
    $$PWD/qtquick2applicationviewer/*.cpp@

    Have a nice day,


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.