No Qt on a new Debian system (resolved!)



  • Hi, when I try to install Qt 5.2 on my new Debian Wheezy 7.3 64 bits system, no "Qt Setup" dialog box appears. Instead I see an error message "Cannot execute binary file", and a zero bytes file appears with a strange filename "?IB@?? (invalid encoding").

    I tried both the online and the offline 64 bits Linux installer, same problem. Also tried "sudo apt-get install build-essential", no dice.

    Note: on my old Debian 64 bits Wheezy (that had Qt 5.1 before) I can install Qt 5.2 just fine. It's just for this new Debian system (installed earlier today) I get this error.

    *** Update ***
    I must be getting old! Just did a 'uname -a' on the Debian system, and it said:
    "Linux debian7 3.2.0-4-686-pae #1 SMP Debian 3.2.51-1 i686 GNU/Linux"

    I.e. I accidentally built a 32 bits system, no wonder those 64 bits installs failed. Sorry my bad, Mondays...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.