Qt Creator 3.0 Welcome Mode not working in VirtualBox VM



  • I originally installed Qt 5.20 with Qt Creator 3.0 on my Win7 64 bit machine and it worked flawlessly. Then I wanted to install it into a Win7 32 bit virtual machine (using VirtualBox). In the VM I start off on the qt-project.org site and download a version. I've tried both the Qt Online Installer for Windows (13 MB) (Info) link and the Qt 5.2.0 for Windows 32-bit (MinGW 4.8, OpenGL, 689 MB) (Info) link. Both installs work and I can compile a simple Hello world demo. However, when Qt starts the Qt Welcome Mode is just a transparent window showing the contents of the desktop. If you change modes and go back to the Welcome mode it will then just show the contents of the previous mode. I would like to have access to the examples and tutorial links.

    I also installed under Kubuntu 13.10 in VirtualBox (on the same Win7 64 bit host) and the Welcome mode works correctly there.

    I'm using VirtualBox 4.3.6 and I have Guest Additions Installed. I'm running a copy of Win 7 Ultimate. The VM is very clean, it has Chrome installed, the latest Win updates and MS Security Essentials and that's about it. The virtual hard disk (vdi) has about 50 Gigabytes of free space after the install.

    I've tried

    1. turning off Windows Firewall and MS Security Essential real time protection.
    2. running as administrator.
    3. running in xp SP2 and SP3, and win95 compatibility modes
    4. running with Aero disabled
      Nothing has helped. Any suggestions? If it's known that VirtualBox isn't compatible I can buy VMWare if that works better.

  • Moderators

    Hi,

    It is probably an OpenGL issue in the VMs. The Welcome screen uses Qt Quick, which requires OpenGL 2.0 support or higher -- all QML applications will show the same symptoms on that VM. See "this report":https://bugreports.qt-project.org/browse/QTBUG-34964 and please add your descriptions to it.

    If you don't use Qt Quick/OpenGL, the rest of Qt Creator should work fine in your VirtualBox VM. Otherwise, I suggest finding out if VMWare has better OpenGL support before buying it.



  • Thanks for the answer. I just finished reinstalling (via another method) on Kubuntu and now under Kubuntu the welcome mode works. I updated my post.

    If it were OpenGL support in VirtualBox I wouldn't have expected that. I downloaded VMWare (free 30 day trial) just to see if it's any better. Once I'm through testing I'll see if I can add something helpful to the bug report.



  • It doesn't work for me when I run it natively on Fedora 20 (64bit), let alone in a VM.


  • Moderators

    You can disable the Welcome plugin and it will work (Help->Plugins...). Or from command line:
    @
    qtcreator -noload Welcome -noload QmlDesigner -noload QmlProfiler
    @

    This should disable all parts of Qt Creator that require OpenGL.


  • Moderators

    Rolias: Try disabling 3d Acceleration on your VirtualBox VM (i.e. switch to software rendering)

    Todd: Can you provide more info about your graphics drivers and supported OpenGL version?



  • [quote author="JKSH" date="1390476989"]Todd: Can you provide more info about your graphics drivers and supported OpenGL version?[/quote]

    This is on my notebook. I'm using the radeon kernel driver for my Trinity [Radeon HD 7520G].

    For OpenGL I get the following...

    OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.5



  • For what it's worth, I loaded Creator onto a virtualbox with WinXP w/Service pack 3 (32 bit), to see if I could re-create the OP's problem, and ended up with an unusable ide.

    I turned off the Welcome plugin and the QML plugins and it seems to work ok now. Turning off 3d acceleration in VirtualBox did NOT make things any better.


  • Moderators

    There are many reports of Qt's OpenGL bits not playing well with VirtualBox,

    Digia is tracking graphics issues. Could you please read http://lists.qt-project.org/pipermail/development/2013-November/014330.html and file a report at https://bugreports.qt-project.org/ ?



  • I will do that. Thank you for your response. :)


  • Moderators

    You're welcome. :) Thank you for your report.



  • As a long overdue follow-up I would like to point out I got this working from advice from Christian Stenger when I reported it as a bug. "I wrote up the work-around.":http://bit.ly/qtvirtbox



  • @Rolias said:

    Thanks for the answer. I just finished reinstalling (via another method) on Kubuntu and now under Kubuntu the welcome mode works. I updated my post.

    If it were OpenGL support in VirtualBox I wouldn't have expected that. I downloaded VMWare (free 30 day trial) just to see if it's any better. Once I'm through testing I'll see if I can add something helpful to the bug report.

    VMWARE version 11 (latest) running Win 7 x64 SP1 and Qt 5.4, displays Welcome Mode Load Error.



  • @JKSH said:

    Rolias: Try disabling 3d Acceleration on your VirtualBox VM (i.e. switch to software rendering)

    Todd: Can you provide more info about your graphics drivers and supported OpenGL version?

    Disabling accleration on VMWARE version 11 does nothing to improve.



  • @astodolski
    This thread saved my day : disabling VirtualBox 3D acceleration made Qt 5.7 OpenGL error disappear. Host : iMac OS-X 10.11, Virtualbox 5.1.4. Qt Guest : Ubuntu 14.04.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.