Error when copiling vlc-1.1.7



  • System : 2.6.34.7-0.7-desktop

    Environment configuration:
    /configure --prefix=/usr/local --x-includes=usr/include/X11 --x-libraries=/usr/lib/X11 --enable-dbus --enable-debug --enable-sout --enable-lua --enable-vlm --enable-live555 --enable-dvdnav --enable-smb --enable-avcodec --enable-postproc --enable-realrtsp --enable-x264 --with-x --enable-opengl --enable-alsa --enable-qt4 --enable-vlc >> configure.txt

    QT-4.7.1

    Error:
    @
    CXX components/libqt4_plugin_la-info_panels.lo
    In file included from /usr/local/Trolltech/Qt-4.7.1/include/QtCore/QVariant:1:0,
    from components/extended_panels.cpp:30:
    /usr/local/Trolltech/Qt-4.7.1/include/QtCore/qvariant.h: In function 'T qvariant_cast(const QVariant&) [with T = QVariant]':
    /usr/local/Trolltech/Qt-4.7.1/include/QtCore/qvariant.h:592:25: error: 'QVariant' is not a member of 'QMetaType'
    make[6]: *** [components/libqt4_plugin_la-extended_panels.lo] Error 1
    make[6]: *** Waiting for unfinished jobs....
    make[6]: Leaving directory /root/projeto/vlc-1.1.7/modules/gui/qt4' make[5]: *** [all] Error 2 make[5]: Leaving directory/root/projeto/vlc-1.1.7/modules/gui/qt4'
    make[4]: *** [all-recursive] Error 1
    make[4]: Leaving directory /root/projeto/vlc-1.1.7/modules/gui' make[3]: *** [all] Error 2 make[3]: Leaving directory/root/projeto/vlc-1.1.7/modules/gui'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory /root/projeto/vlc-1.1.7/modules' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory/root/projeto/vlc-1.1.7'
    make: *** [all] Error 2
    @
    Should somebody gime a help?
    Regards.



  • If your having trouble compiling vlc from source you would be better off asking aether.

    A. In the vlc support forum.
    B. Your "linux" distribution forum.

    Now if you have a problem with a project that your building that uses the phonon-vlc plugin then I am sure some one here can help.



  • Ok.Thanks


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.