"QtMultimediaKit" is not installed Problem



  • Hi All,
    I m using Qt SDK 1.1 Technology Preview. I want to make some audio/video application.for that i have define
    CONFIG += mobility MOBILITY = multimedia in .pro file and in qml file import QtMultimediaKit 1.1.
    when i am running application then i am getting error "QtMultimediaKit" is not installed.
    I have searched in sdk and i founded QtMultimediaKit.

    please tell me why i am getting this error.



  • What are you trying to run this in? Simulator? Your Phone(Symbian or Maemo)? Little more info please.



  • hi,
    thanks for you reply. i am trying to build it on Simulator.



  • Just for giggles put this in your PATH C:\QtSDK\Simulator\QtMobility\mingw\lib Obviously you might have to change the drive letter. Wondering if it just isn't seeing the libs that are required to see the QtMobility Modules. Google how to add things to your PATH for which ever operating system you are using.



  • hi,
    Now i facing this error

    QMediaPluginLoader: Failed to load plugin: "C:/QtSDK/Simulator/Qt/mingw/plugins/mediaservice/qsimulatorengine.dll" "The plugin 'C:/QtSDK/Simulator/Qt/mingw/plugins/mediaservice/qsimulatorengine.dll' uses incompatible Qt library. Expected build key "Windows mingw debug full-config", got "Windows mingw release full-config""
    QMediaPluginLoader: Failed to load plugin: "C:/QtSDK/Simulator/Qt/mingw/plugins/mediaservice/qtmedia_audioengine.dll" "The plugin 'C:/QtSDK/Simulator/Qt/mingw/plugins/mediaservice/qtmedia_audioengine.dll' uses incompatible Qt library. Expected build key "Windows mingw debug full-config", got "Windows mingw release full-config""
    defaultServiceProvider::requestService(): no service found for - "com.nokia.qt.mediaplayer"



  • That is a known error. I forget which bug number that is from Nokia but it fully documented. It just means it won't actually play the video/audio in the simulator. If that is all you got then I say it is time to port it over to a device and test. If it won't build for a specific device you might have to install the QtMobility from the source. But the way that error reads, I get it everytime I build in simulator and it works for my device. If building for n900 there are more steps specifically for that device and is documented in a thread on this board.



  • means i can not test audio or video on the simulator.



  • Correct you cannot listen to or view audio/video in the simulator of Qt SDK 1.1 Technical Preview. It is a known problem and they plan to fix this issue.



  • thanks for correcting me.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.