Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Compiling from repository with mingw64, webkit problem



  • I'm compiling 5.2.0 stbale from the repo. So far everything went smooth. Now I encountered a problem which doesn't have an obvious solution for me.

    @mingw32-make[4]: Entering directory 'e:/devel/qt-5/qtwebkit/Source'
    g++ -Wl,-s -shared -Wl,--out-implib,E:/devel/qt-5/qtbase/lib/libQt5WebKit.a -o E:/devel/qt-5/qtbase/lib/Qt5WebKit.dll .obj/release/qrc_WebCore.o .obj/release/qrc_WebKit.o .obj/release/qrc_InspectorBac
    kendCommands.o -lglu32 -lopengl32 -lgdi32 -luser32 -Le:/devel/icu/dist/lib -Le:/devel/openssl-1.0.1e/dist/lib -Le:/devel/icu/dist/lib -Le:/devel/openssl-1.0.1e/dist/lib -LE:/devel/qt-5/qtbase/lib -lQ
    t5Network -LE:/devel/qt-5/qtbase/lib -lQt5Gui -LE:/devel/qt-5/qtbase/lib -lQt5Core .obj/release/Qt5WebKit_resource_res.o -Wl,-whole-archive -lWebKit1 -Wl,-no-whole-archive -LE:/devel/qt-5/qtwebkit/Sou
    rce/WebKit/release -Wl,-whole-archive -lWebKit2 -Wl,-no-whole-archive -LE:/devel/qt-5/qtwebkit/Source/WebKit2/release -Wl,-whole-archive -lWebCore -Wl,-no-whole-archive -LE:/devel/qt-5/qtwebkit/Source
    /WebCore/release -lz -ladvapi32 -lgdi32 -lshell32 -lshlwapi -luser32 -lversion -lglu32 -lopengl32 -lgdi32 -luser32 -lgdi32 -lole32 -luser32 -Wl,-whole-archive -lANGLE -Wl,-no-whole-archive -LE:/devel/
    qt-5/qtwebkit/Source/ThirdParty/ANGLE/release -Wl,-whole-archive -lJavaScriptCore -Wl,-no-whole-archive -LE:/devel/qt-5/qtwebkit/Source/JavaScriptCore/release -lwinmm -Wl,-whole-archive -lWTF -Wl,-no-
    whole-archive -LE:/devel/qt-5/qtwebkit/Source/WTF/release -licuin -licuuc -licudt -lwinmm -lgdi32 -LE:/devel/qt-5/qtbase/lib -lQt5Quick -LE:/devel/qt-5/qtbase/lib -lQt5Multimedia -LE:/devel/qt-5/qtbas
    e/lib -lQt5Qml -LE:/devel/qt-5/qtbase/lib -lQt5Sql -LE:/devel/qt-5/qtbase/lib -lQt5Gui -LE:/devel/qt-5/qtbase/lib -lQt5Network -LE:/devel/qt-5/qtbase/lib -lQt5Positioning -LE:/devel/qt-5/qtbase/lib -l
    Qt5Sensors -LE:/devel/qt-5/qtbase/lib -lQt5Core

    E:/devel/qt-5/qtwebkit/Source/WebCore/release/libWebCore.a: member E:/devel/qt-5/qtwebkit/Source/WebCore/release/libWebCore.a(SVGAllInOne.o) in archive is not an object

    collect2.exe: error: ld returned 1 exit status

    Makefile.api.Release:81: recipe for target 'E:/devel/qt-5/qtbase/lib/Qt5WebKit.dll' failed

    mingw32-make[4]: *** [E:/devel/qt-5/qtbase/lib/Qt5WebKit.dll] Error 1
    mingw32-make[4]: Leaving directory 'e:/devel/qt-5/qtwebkit/Source'
    Makefile.api:38: recipe for target 'release-all' failed
    mingw32-make[3]: *** [release-all] Error 2
    mingw32-make[3]: Leaving directory 'e:/devel/qt-5/qtwebkit/Source'
    Makefile.QtWebKit:40: recipe for target 'sub-api-pri-make_first-ordered' failed
    mingw32-make[2]: *** [sub-api-pri-make_first-ordered] Error 2
    mingw32-make[2]: Leaving directory 'e:/devel/qt-5/qtwebkit/Source'
    Makefile:303: recipe for target 'sub-Source-QtWebKit-pro-make_first-ordered' failed
    mingw32-make[1]: *** [sub-Source-QtWebKit-pro-make_first-ordered] Error 2
    mingw32-make[1]: Leaving directory 'e:/devel/qt-5/qtwebkit'
    Makefile:421: recipe for target 'module-qtwebkit-make_first' failed
    mingw32-make.exe: *** [module-qtwebkit-make_first] Error 2
    @

    Any help would be greatly appreciated.



  • did you install msvc 12 express ??


Log in to reply