QtCreator debug helpers for STL not accessible on win7



  • Hi,
    I'm using Qt5.2 with mingw 4.8 on win7.
    Debugger helpers for STL containers didn't work for me out the box. It was showing me "not accesible" on every STL container I tried to look into. Qt containers & types were shown correctly and I checked python installation was ok.

    Workaround:
    Later just by accident I managed to solve the problem by commenting out everything in gdbinit file (Qt5.2.0\Tools\mingw48_32\etc). I have no idea if it is a bug. Has anyone expereinced the same and should it be reported ?
    Thank you



  • under linux is the same, if you still get <not accessible> make sure that both debugger options [Load .gdbinit file on startup] and [Load system GDB pretty printers] are disabled.



  • I was having a similar problem when I upgraded to Qt Creator 3.0 (Windows 7), but I was unable to view the contents of various Qt Classes. I didn't spend a lot of time looking into the problem since it was a low priority and went back to using Qt Creator 2.7. I just tried Terenty's recommendation and commented out everything in gdbinit, and I need to do more testing but it looks like that may have worked.



  • Thanks!

    Disabling the debugger options as suggested by dmarinescu fixed it for me on both Linux and Mac.

    I consider this a bug and I'll check if there is already a bug report.

    Edit: According to bug report QTCREATORBUG-11290 this should be fixed in qtcreator 3.1.0.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.