ANDROID_NDK_ROOT missing



  • I have installed the android ndk and qt 5.2. I launch qtCreator and follow the description on how to make the Notepad demo program. Compilation goes fine, but when I try to run I get the message: "You need to set the ANDROID_NDK_ROOT environment variable to point to your Android NDK.". I have set this variable:

    env |grep NDK
    ANDROID_NDK_ROOT=/opt/android-ndk-r9b/

    ..... but that changes nothing. I have also run the script setenv-android.sh setting a bunch of parameters, but this also changes nothing. Anyone??

    I use Fedora 20.



  • it's about the internal settings for QtCreator, not about environmental variables.

    Tools -> Options -> Android



  • Oh, yeah. Thanks.



  • If anyone is having this problem on windows try adding a new environment variable to windows (outside of Qt Creator), ANDROID_NDK_ROOT and giving it the path (C:\Android\AndroidNDK e.g.). In order to get my system to work I had to:

    1. Create this variable in Windows environment variables
    2. Have the setting in my Qt environment variables
    3. have the setting in Qt->Tools -> Options -> Android..

    I am using Windows 64 bit.
    Qt 5.2

    So you would add it to System->Advanced system settings->Environment variables->new...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.