[Solved] Include directory not right when building Qt 5.1.1 from source



  • I have the regular 5.1.0 binary distribution installed on my old computer, but for my new development system I'm building 5.1.1 from source for a variety of reasons I won't bore you with. Everything seems to work well; the build completes without errors and everything ends up looking as I'd expect it to, except for the "include" directory which is generated in the working directory by 'make'.

    My home-built 'include' directory has subdirectories for each of the major Qt modules, as I'd expect, but inside these subdirectories there are just single files - for example, the 'QtWidgets' subdirectory contains a single file called "QtWidgetsDepends" (with no suffix) instead of what I'd expect, namely qabstractbutton.h, qabstractitemdelegate.h etc.

    I've experimented with various different configuration options, but none seem to make any difference; the result is the same in each case. For the record, here is my build batch file:

    @
    CALL "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\vcvarsall.bat" amd64
    set PATH=C:\Qt\5.1.1\src\qtbase;C:\Qt\5.1.1\src\qtrepotools\bin;C:\Qt\5.1.1\src\gnuwin32\bin;C:\Qt\jom;%PATH%
    set QMAKESPEC=win32-msvc2010

    configure -opensource -opengl desktop
    jom
    @

    Please can someone point out to me what I'm doing wrong here?



  • (Slaps head, says 'd-oh!')

    I left out two important steps:

    1. Include '-prefix C:\Qt\5.1.1\x86_64' (for example) at the end of the 'configure' statement
    2. Put 'jom install' on the next line after the first 'jom' command.

    ...and now it works fine.



  • Pls edit your topic to include "SOLVED" :)



  • Aha, so that's how it works! I'd been trying to find a 'solved' check box on the web page to tick.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.