Python for Qt version 1.0.0~beta5 "color blind" released



  • The PySide team is happy to announce the fifth beta release of PySide:
    Python for Qt. New versions of the PySide toolchain components
    have been released as well.

    This is a source code release only; we hope our community packagers will
    be providing provide binary packages shortly. To acquire the source code
    packages, refer to our download wiki page [1] or pull the relevant
    tagged versions from our git repositories [2].

    Major changes since 1.0.0~beta4

    This is a bugfix release. Since beta4, a total of 23 bugs have been
    fixed. See the list of fixed bugs at the end of this message.

    Path towards 1.0 release

    The list of bugs in our Bugzilla [3] having P3 or higher priority is
    getting short enough that we are beginning to feel confident for to do
    the 1.0 release soon. The next release, in two weeks, will be our first
    release candidate (rc1): it will incorporate all or most of the
    currently open P2/P3 bugs, but after that, only clear regressions
    (features which have worked in previous PySide versions but not in rc1)
    will be fixed before 1.0. Then, the 1.0 release will happen two weeks
    from rc1.

    About PySide

    PySide is the Nokia-sponsored Python Qt bindings project, providing
    access to not only the complete Qt 4.7 framework but also Qt Mobility,
    as well as to generator tools for rapidly generating bindings for any
    Qt-based libraries.

    The PySide project is developed in the open, with all facilities you'd
    expect from any modern OSS project such as all code in a git repository
    [2], an open Bugzilla [3] for reporting bugs, and an open design
    process [4]. We welcome any contribution without requiring a transfer of
    copyright.

    List of bugs fixed

    • 640 Crash in example elasticnodes.py
    • 627 Compile error in generatorrunner - missing abstractmetalang.h, etc
    • 632 QLineEdit.getTextMargins() segmentation fault
    • 647 QGLWidget.bindTexture(QPixmap) causes program crash
    • 650 Missing bindings for QNetworkProxyFactory
    • 651 Calling disconnect() with no arguments causes segfault
    • 562 pyside-uic does not generate some layers properties
    • 565 QImage missing *data constructors
    • 590 Error QFileDialog.getSaveFileName with DontConfirmOverwrite option
    • 593 repr should be more Pythonic
    • 605 Using metaclasses with the PySide classes doesn't work
    • 612 QColor.reduce is not accurate
    • 613 QSvgRenderer chooses QByteArray overload when given a file path
    • 616 error compiling when public and private methods differ by the const-ness
    • 617 conversion from C++ enum to PySide does not set repr() properly
    • 618 QAbstractItemModel.createIndex only creates a weak reference to ptr
    • 633 bool of null QDate (possibly other empty QString/null QObj types?) returns True for empty instance; probably should be False
    • 641 some errors in diagramscene.py
    • 655 bad re-implementations of QApplication.notify result in a SystemError
    • 656 cannot inherit from QCoreApplication
    • 659 removeParent() performs very poorly when a parent has >10000 items
    • 566 'PySide.QtGui.QImage' object has no attribute 'scanLine'
    • 636 Unable to navigate back to the main site from the generated documentation

    References

    [1] http://developer.qt.nokia.com/wiki/PySideDownloads
    [2] http://qt.gitorious.org/pyside
    [3] http://bugs.openbossa.org/
    [4] http://www.pyside.org/docs/pseps/psep-0001.html



  • It was said that this would be released two weeks after beta 4, but it was released last week! What made you release this new (and last) beta that soon?



  • The last release was at January 21th, this new yesterday juts 13 days after, because our "sprint " is in the end and we fixed the planned bugs faster than we thought, and all task as done 2 days earlier. :D

    Working hard to get 1.0.0 ASAP. :D


Log in to reply