QTWebEngine not building



  • Hi,

    I followed the instructions for cloning the Qt WebEngine source, under http://qt-project.org/wiki/QtWebEngineHowToTry, and tried to build the whole project. It built fine until about a month ago, but since then the tree has been continuously broken.

    Even doing a fresh clone and make fails, and always with this error:
    ^
    ../../src/core/content_browser_client_qt.cpp: In member function ‘virtual void ShareGroupQtQuick::AboutToAddFirstContext()’:
    ../../src/core/content_browser_client_qt.cpp:261:36: error: ‘sharedOpenGLContext’ is not a member of ‘QSGContext’
    QOpenGLContext *shareContext = QSGContext::sharedOpenGLContext();
    ^
    ninja: build stopped: subcommand failed.
    make[3]: *** [invoke_ninja] Error 1
    make[3]: Leaving directory /home/pds/work/qtwebengine/src/core' make[2]: *** [sub-gyp_run-pro-make_first] Error 2 make[2]: Leaving directory/home/pds/work/qtwebengine/src/core'
    make[1]: *** [sub-core-make_first] Error 2
    make[1]: Leaving directory `/home/pds/work/qtwebengine/src'
    make: *** [sub-src-make_first] Error 2

    This error always occurs during the final linking, on the object 8982/8983 or the Ninja build.

    Can someone help me resolve this, or else post a Last Known Good Release of the QT WebEngine source tree which builds, while I wait for this tree to stabilize ? I really need this since I'm working on an External project integrating with QTWebEngine and Chromium, and have had to go back to using the QTWebKit widgets as a fallback while waiting for QTWebEngine to be fixed.

    I am building on Fedora 19, and have tried with both QT 5.1 and QT 5.2 Beta, neither of which works.

    Thanks,

    pfdsouza



  • Ok, the issue was QT 5.2 Beta. Once I uninstalled that and went back to using Qt 5.1.1 it built.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.