[Moved] Qt Creator doesn´t find my .libs in Linux.



  • I have been working in windows for some weeks and things seems to works. After sometime working in windows I went to linux and problems starts.

    I have a multiproject. One of then is a app template and the other ones are libraries. So I have a all.pro that is a template subdirs that includes all my other projects.

    @
    TEMPLATE = subdirs

    DESTDIR = ../build

    SUBDIRS = Database
    Exceptions
    Utils
    Importers
    Types
    Nrtq
    xCdr
    Syncronizer \

    CONFIG += ordered
    CONFIG += warn_on
    @

    I have DESativated the shadows builds in the IDE and I have defined in every project the target dir and the destdir, like this:

    @
    TARGET = Database
    TEMPLATE = lib

    INCLUDEPATH+=../xCdr
    INCLUDEPATH+= ../Types

    DESTDIR = ../build
    @

    The thing is that if I go to console I set LD_LIBRARY_PATH to the right folder in which there are all my .so and it works, but if I run the application from the IDE it can't finde any .so that I create.

    I have tried to set the LD_LIBRARY_PATH in run settings, in build settings, but problems go on.

    Any idea about how to fix this problem? I am using QT creator 2.0 but problems are the same in 1.3.

    Thanks in advance for your help.

    [EDIT: formatting fixed, please use @-tags for .pro snippets, Volker]



  • Try to set LD_LIBRARY_PATH in Projects->build Envitonment



  • I set up the LD_LIBRARY_PATH in both places. Project->Build Settings -> Build Enviroment and in Project -> Run Settings -> Run Enviroment.

    Problems are the same :-(



  • I have just fixed it, but using a workaround. I create a little bash script that set the LD_LIBRARY_PATH from console and after that open qtcreator. In this way qtcreator knows about this, but if I set up the vlbe using the IDE, it seems that qtcreator just ignore it. Perhaps a bug...



  • Moved to Tools forum, as it's a Qt Creator problem.

    Did you try version 2.1 RC1? It contains many improvements and maybe solves the environment problem too.



  • I use LD_LIBRARY_PATH on both ubuntu and fedora
    Just set it in qt creator in run environment and it should work (at least for me its working with stable and rc build of creator)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.