Configure -static Failed



  • Hello,

    I am trying to build my Qt source package statically but the initial command of configure -static fails and I cannot proceed. Below is the part of the output from the command line:

    @
    D:\qt-5.1.0>configure -static

    D:\qt-5.1.0>/* -- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offse
    t: 2 -
    - /
    '/
    ' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>/* ***** BEGIN LICENSE BLOCK *****
    '/*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* Version: MPL 1.1/GPL 2.0/LGPL 2.1
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>*
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* The contents of this file are subject to the Mozilla Public Licens
    e Version
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* 1.1 (the "License"); you may not use this file except in complianc
    e with
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* the License. You may obtain a copy of the License at
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* http://www.mozilla.org/MPL/
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>*
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* Software distributed under the License is distributed on an "AS IS
    " basis,
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* WITHOUT WARRANTY OF ANY KIND, either express or implied. See the L
    icense
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* for the specific language governing rights and limitations under t
    he
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* License.
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>*
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* The Original Code is Mozilla Communicator client code, released
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>* March 31, 1998.
    '*' is not recognized as an internal or external command,
    operable program or batch file.

    D:\qt-5.1.0>*
    '*' is not recognized as an internal or external command,
    operable program or batch file.@


  • Moderators

    You need to install all Qt dependencies, especially Perl. Otherwise, configure will not work!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.